Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

All the terminal fonts I have tried result in inaccurate rendering of the Devanagari sript (and/or Roman script) in the Terminal

In the Devanagari script, a vowel binds itself to a preceding consonant. This type of vowel does not exist on its own. The dotted circle indicates that it requires a preceding consonant...
Here is an example of an as yet unattached vowel: VOWEL SIGN O'

Proper font rendering does the work of grafting the consonanat to the vowel, and should remove all visible signs of the dotted-circle....

...but I can't find a Terminal font which renders both the Roman script and Devanagari scripts satisfactorily. Actually, the dotted-circle still shows for ALL Devanagari fonts, and the Roman script is not rendered properly for many of those fonts; eg. in the word "Primer", about 40% of the "e" overlaps the "m".

Is there some way around this?
Does anyone know of a suitable font?... Mono-spaced is preferred.
Or is it something to do with the Ubuntu - gnome-terminal setup?

Update 2:
I tried the same text in openSUSE (gnome-terminal): it failed worse than Ubuntu.
I tried the same text in Fedora (Konsole): it rendered PERFECTLY!
but that's Fedora, and I'm using Ubuntu :(
okay, then next obvious step:
I installed Konsole in Ubuntu: it rendered PERFECTLY!
but that's Konsole, and I'd rather stay in the gnome family... and Konsle's menu doesn't respond to keyboard... and If Ubuntu+Konsole can do it, then there is probably a way Ubuntu+gnome-terminal can...

Update 1:
As suggeseted, here are some examples.
The Devanagari looks okay here, but not in the termainal (the .png below shows the Monospace font)

30 - Uncle moon – चंदा मामा/20081119 Hindi Primer part 30 - Uncle moon – चंदा मामा.nag
31 - Rain Queen - वर्षा रानी/20081124 Hindi Primer part 31 - Rain Queen - वर्षा रानी.nag

alt text

Actually, NONE of the Devanagari-aware fonts render correctly!
...and some of the the Roman script rendering can get pretty whacky.

All entries from the command $ locale are set to "en_AU.UTF-8", but even setting everything to "hi_IN.UTF-8" makes no difference

share|improve this question
2  
Could you add some real-world sample text in Devanagari script so that people can try out different fonts they may have? –  Stefano Palazzo Oct 20 '10 at 16:21
1  
There's some preliminary work been done on adding devanagari to the Ubuntu font family, so there's a chance this will work better in future: design.canonical.com/2010/09/charactersets –  misterben Oct 21 '10 at 19:27
add comment

1 Answer

up vote 6 down vote accepted

I reckon that this is a bug, and is beyond a simple "choose a better font" issue.

The same fonts, including the default Monospace, work fine in all other apps I've tried.
and Devanagari fonts doesn't render properly in Fedora's gnome-terminal either, but the same fonts works in KDE's Konsole and also in Konsole running in Ubuntu.

I don't know how to follow a reported and accepted bug, but I found a reference to a gnome-terminal / Devanagari issue (from December of 2008)... and perhaps this is the same issue.

vte (Ubuntu) low (priority) Assigned to: Ubuntu Desktop Bugs
https://bugs.launchpad.net/vte/+bug/310053

...and now that I've played with Konsole a bit more, it has revealed some really nice features... especially Search Output with Regex... wow! Just what I wanted... and the lack of menu-accelerator Keys don't matter, becaue it has fully Kustomizable short-cut Keys... I'm Konverted.... and I've found my good mono-space font. It is called Monospace :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.