Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have NVIDIA Geforce GT 540M. I have a problem with "3D acceleration". Every game I install tells me "you don't have 3D acceleration". What can I do to enable 3D acceleration on my computer?

share|improve this question
2  
Probably you haven't installed the proprietary Graphics card driver for Nvidia cards –  Mysterio Dec 1 '11 at 17:03
    
You should look similar answers regarding Optimus technology: you won't be able to use NVidia card unless you use something like Bumblebee or IronHide. –  Salem Dec 1 '11 at 19:16
1  
See this question: askubuntu.com/questions/36930/… –  Jorge Castro Dec 2 '11 at 15:52

6 Answers 6

the GT 540M indicates that you have optimus technology. Optimus allows you to choose between the Intel GPU that is part of the Core i Series processors and the discrete chip (the Nvidia GT 540M).

There are two things I would do:

Check your bios settings and see if you can set the video card to use the discrete graphics only. This is not available on all bioses, but if it is there you will have the options of:

Optimus

Discrete

Integrated

Choose Discrete.

Then upon completing the boot ensure the Nvidia proprietary drivers are installed. There should be no need to use the PPA; simply use

System Settings > Additional Drivers

That should then give you options for your Nvidia card.

I hope that helps.

share|improve this answer

Go to: http://www.geforce.com/drivers/ Select your Model (GT 500M Series) Select OS: Linux (32/64 bit) Download linux drivers, run it and enjoy.

share|improve this answer

did you install proprietary driver? you can use this ppa to install latest(currently 290.10) nvidia driver.

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-graphics-drivers nvidia-settings
share|improve this answer
    
hmm it dosn't work :( E: Impossible de trouver le paquet nvidia-graphics-drivers –  TheMurdre Dec 1 '11 at 17:25
    
use this command with net connection enabled (omit the last one), then use additional diveer apps (search it in dash) or search "nvidia" either in software center or synaptic. –  jahid65 Dec 1 '11 at 18:13

I had a similar problem on my Dell 1510 and I added the xorg-edgers ppa. I have no idea if it will work for you, but if you have ppa-purge installed then its worth a shot.

share|improve this answer

I have two laptop. The first one is DELL vostro 1510 with GeForce 8400 M GS grapghic card. The second one is DELL XPS with GeForce GT 540 M. I have solved the problem of the first one using:

sudo add-apt-repository ppa:aaron-haviland/cuda-4.0
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install nvidia-cuda-gdb nvidia-cuda-toolkit

But I cannot find a good repository for the second one.

share|improve this answer

Please have a look at switcheroo or acpi-call in order to solve hybrid graphics card problems. google will help.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.