Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am connecting to vpnc which breaks my internet connection. I understand, that this is because all my traffic is forwarding to vpnc now, so the problem is about routing.

So, how can I manage my routes so only one port (1433) will use vpnc and all other connection won't pass traffic through vpn

share|improve this question
    
possible duplicate of askubuntu.com/questions/3518/… –  Amey Jah Dec 1 '11 at 17:26
    
I can't access to vpnc settings through network manager (I have got just vpnc config file) –  fl00r Dec 1 '11 at 17:58
    
Linking this question and also this for future Googlers. I found those answers to work for one of my machines and the one here to work for another. –  bcmcfc Jul 30 at 8:54

2 Answers 2

up vote 2 down vote accepted

I think I have a solution. Please follow the procedure as mentioned below;

  1. Open Network connection and click on VPN tab.
  2. Click on VPN to be configured.
  3. Now click on Edit
  4. Go to IPV4/6 Settings
  5. Click on Routes button
  6. Now check the box in front of the text "Use the connections only for the resources on its network" (This will solve the problem of breakage of your internet connection)
  7. Add a route using add button. (I am not expert in adding routes, so wont be able to help you out here. But this is the way, you would be able to add the routes).
share|improve this answer
    
Cool! But I can't access to vpnc settings through network manager (I have got just vpnc config file) –  fl00r Dec 1 '11 at 17:58
    
I have installed network-manager-vpnc so it works with Cisco VPN as well now. Thanx! –  fl00r Dec 2 '11 at 7:21

infact that with my vpn connection (ubuntu 10.04) i still could not connect to internet though i have already set "Use the connections only for the resources on its network" and "ignore auto obtain route...". This because network manager vpn alway add route 0.0.0.0 0.0.0.0 0.0.0.0 U 0 0 0 ppp0 when it connect. So i need to change default root again with add default gateway command: sudo route add default gw 192.168.2.1 dev eth0 192.168.2.1 --> is gateway which i connect to internet. And it's fine!

share|improve this answer
    
You can use MarkDown to format your answer. –  0xC0000022L Jul 3 at 18:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.