Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have this script

#!/bin/bash
cd /home/user/somedir
pwd

it works as expected, but I would like this script to transport me to /home/user/somedir, but I stay in the same dir.

How to write script that will transport me (in gnome-terminal) to /home/user/somedir?

share|improve this question
2  
possible duplicate of Why doesn't "cd" work in a shell script? – muru Dec 4 '14 at 18:15

You need to source your script. If not it will be run in a separate subshell, changing the working directory of the subshell but not of the shell you run it in.

To source it :

. myfile.sh

or

source myfile.sh

You can read more here

share|improve this answer
    
I was just going to add that.... UAdadapter if you were running the shelll script like sh myfile.sh or ./myfile.sh it would run as danjil described. Either of danjil's options should work for you. – itnet7 Dec 1 '11 at 12:21

Use exec bash at the end

A bash script operates on its current environment or on that of its children, but never on its parent environment.

However, this question often gets asked because one wants to be left at a bash prompt in a certain directory after the execution of a bash script from another directory.

If this is the case, simply execute a child bash instance at the end of the script:

#!/bin/bash
cd /home/user/somedir
exec bash
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.