Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i am trying to make a metapackage with equivs, creating the package is working perfect, but installing it is giving me an error:

Selecting previously deselected package testdeb.
(Reading database ... 219619 files and directories currently installed.)
Unpacking testdeb (from testdeb_1.0_all.deb) ...
dpkg: dependency problems prevent configuration of testdeb:
testdeb depends on apache2; however:
Package apache2 is not installed.
dpkg: error processing testdeb (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
testdeb

to fix that i have to run: apt-get install -f

is there a way around this ?

share|improve this question
1  
Are you installing with dpkg -i? AFAIK dpkg doesnot resolve dependencies apt does. dpkg just refers to missing dependencies if any. –  sagarchalise Dec 1 '11 at 2:19
    
yes i tried that for testing on my local machine, installing via apt is working, thanks ! –  sven Dec 1 '11 at 9:21
    
@sagarchalise can you post that as an answer? :) –  Stefano Palazzo Jan 11 '12 at 13:12

1 Answer 1

Posting comment as the answer:

Are you installing with dpkg -i? AFAIK dpkg doesnot resolve dependencies apt does. dpkg just refers to missing dependencies if any. – sagarchalise Dec 1 '11 at 2:19

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.