Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a somewhat generic prism2-based wireless card plugged into a PCMCIA adapter. In Lucid it was working with orinoco_cs, or at least that's what it does when I boot Maverick with the Lucid kernel. However the Maverick kernel gives a message about orinoco_cs being disabled for Prism2 cards because the hostap driver supposedly supports them better.

It does look like the hostap driver is loading, and I get two devices responding to iwconfig, named wifi0 and wlan2. However they won't seem to connect to the access point.

I am using manual configuration via /etc/network/interfaces and the command line. At one point when the interface was down I saw iwconfig report that wlan2 had in fact connected to the access point, but when I ran ifup wlan2 it disconnected from the AP and the rate changed back to 2M. The encryption key in the interfaces file is the same one I gave on the iwconfig command line. Further command line poking did not seem to get things associated.

What am I missing?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I installed hostap-utils. By itself that was not enough. Then I did the following:

(a) Changed the interfaces file to use some of the hostap_utils commands instead of some of the iwconfig-related entries.

auto wlan2
iface wlan2 inet static
address desired ip
netmask 255.255.255.0
gateway desired gateway address
wireless-essid my network id
# wireless-mode managed
# wireless-key my network key
# wireless-rate 11M
up prism2_param wlan2 oper_rates 15
up prism2_param wlan2 ap_auth_algs 2
up hostap_crypt_conf wlan2 ff:ff:ff:ff:ff:ff WEP my network key

(b) hostap_cs was creating two network devices which were not quite independent. In the interfaces file I had settings for only one of them. From /var/log/daemon.log it looked like NetworkManager was trying to claim the other. I added an entry for it, rebooted, and the network seems OK now.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.