Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Somehow, I activated the on-screen keyboard (Onboard) in the unlock screen and I can't deactivate it now. I've restarted the computer, but it's still there in the unlock screen.

How can I deactivate the on-screen keyboard in the unlock screen?

share|improve this question
    
This is a related question: askubuntu.com/q/62964/55343 –  user1251007 Nov 20 '13 at 9:56
add comment

3 Answers 3

up vote 69 down vote accepted

GUI method

Search for Onboard settings from the gnome-shell overview.

Under General tab and Desktop integration heading, uncheck the option Show Onboard when unlocking the screen.

enter image description here

Command-line method

Thanks to fossfreedom's answer to a similar question

Run the following command in a terminal:

gsettings set apps.onboard xembed-onboard false

If the above is not working, try this one:

gsettings set org.gnome.desktop.screensaver embedded-keyboard-enabled false

worked for me (Ubuntu 12.04).

share|improve this answer
2  
Thanks. This is what I was looking for. I'm not sure how I activated these settings in the first place though. –  Thucydides411 Nov 30 '11 at 17:02
    
It's also happens to me, and I did a bug report. Please, go to this link bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/986843 and tick in the green text "is this bug affecting you?" to indicate that it also happens to you. Thank you =) –  Carlos Soriano Sánchez Apr 22 '12 at 13:01
    
Note that this isn't specific to Gnome Shell. I was bitten by this bug in Unity. –  Scott Severance May 2 '12 at 8:36
    
Scott Severance: Ok, I take into account in the bug report =) thank you. –  Carlos Soriano Sánchez May 2 '12 at 17:45
add comment

In the Dash, open Onboard Settings.

enter image description here

Unmark Show Onboard when unlocking the screen.

enter image description here

Done.

share|improve this answer
    
Not sure how I missed that. Thanks! –  Patrick Marchwiak Feb 22 '12 at 21:46
add comment

On login page of ubuntu, click human icon on top bar then un check onscreen keyboard.

share|improve this answer
add comment

protected by Community Jan 21 at 13:46

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.