Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to narrow down a bug (to eventually report it or give up if it'll turn out that resetting a simple setting will be enough to get rid of it)

I noticed that with a brand new user the bug doesn't pop up

so I tried to reset the config of my user's nautilus

I renamed .config/nautilus I renamed .nautilus2 (strange name... why the 2?) and I did a

gsettings reset-recursively org.gnome.nautilus

strangely enough, it didn't work:

as an example (otherwise this is completely uninteresting) I previously set up to use my home as the desktop folder, and now the key has correctly been resetted

$gsettings get org.gnome.nautilus.preferences desktop-is-home-dir 
false

and yet on my desktop I see the contents of my home folder (meaning that the dconf settings are not being respected)

I know that with the transition to gtk3 there've been lots of changes (before I should've used gconf... but now there's dconf and gsettings), so there're quite a bit of questions here about nautilus... but these unfortunately now seem to be outdated

share|improve this question
    
Within the last sentence, you appear to have answered your question fully. Can we do something else (as community) to satisfy your question? –  aquaherd Nov 30 '11 at 17:00
    
No, I haven't answered it, in my last sentence I just preemptively warned people who may be answering too hastily, that my situation is quite different from the one described in other questions concerning nautilus (at least the ones I've looked into) –  berdario Dec 1 '11 at 11:49
    
I don't know enough about your problem to give a real answer, but I have a suggestion. I was able to view/edit my dconf settings using dconf-editor in the dconf-tools package. For some reason, even though I never needed gconf-editor, dconf seemed much more involved. –  TechZilla Dec 29 '11 at 20:20

1 Answer 1

Don't believe this is a bug, gsettings should enable/disable that option & you'd see the change immediately

You could try toggling it once with the set command, set to true, then back to false.

User gsettings are stored in 1 file - ~./config/dconf/user

Though you can't read that file easily, you could move or delete it, then do a log out/in & see

share|improve this answer
    
this isn't enough apparently: I tried just that and some settings are retained (probably it's fetching them from somewhere else?) such as the desktop-is-home-dir or also some other things, like the teme (I use radiance, and by renaming .config/dconf/user I got windows with a mixed ambiance/radiance theming, look at the screenshot: ubuntuone.com/4YxfXm9ZFxZkexg4P0lHWl ) –  berdario Dec 1 '11 at 11:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.