Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

HP Compaq 6200 Pro MT desktop machine. I installed Ubuntu 10.04.3 LTS server edition. The installer said that it could not detect the network hardware, despite an ethernet cable being plugged in and a link light showing; I tested the cable/connection/node on another machine and it works. I completed the installation, but Ubuntu does not detect the ethernet card. lspci shows the card, but reports <access denied> for some of the specifications.

I booted off a CrunchBang Linux (Debian-based) live USB and it detects the network card and I get an IP address.

Rebooted into Ubuntu server -- no network connectivity on the ethernet card.

Suggestions?

Update: Installed Debian 6.0.3 (CD1) from USB. It detected the network card during installation and configured the network. I rebooted into Debian and network was working; the machine has an IP address.

share|improve this question
    
well you already found out that you can use lspci to find out which networking card it is - please let us know as well :-) –  Michael K Nov 30 '11 at 11:57
    
Ethernet controller: Inter Corporation Device 1502 (rev 04); Subsystem: Hewlett-Packard Company Device 1497 –  SabreWolfy Nov 30 '11 at 12:04
    
Debian install also shows access denied as the Ubuntu one did, but provides more information about the NIC. It's an Intel 82579LM using kernel driver e1000e. –  SabreWolfy Nov 30 '11 at 13:03

1 Answer 1

up vote 6 down vote accepted

Ubuntu 10.04 LTS does not support the Intel 82579LM NIC as detailed here; instructions on downloading and installing the driver are provided there too. An expired bug report on this issue is here.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.