Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Unity 2D as my desktop, and it works fine most of the time, but every now and then, I try to Alt-Tab to switch to a different application, and instead of switching to that window, the launcher bar opens, and the icon of the application I was trying to switch to starts jiggling.

If I try to switch to something else, that icon starts jiggling too. If I click on the icon with the mouse, then it stops jiggling and switches to the requested window.

What is this behavior? I haven't seen any mention of jiggling icons in Unity. I don't understand the original purpose of this, and I'd like a way to fix it so that I won't have to use the mouse.

EDIT: I get that this is a bug, but someone must have had to code that jiggling effect. What is it used for? Is it some relic of old behavior, or something new that hasn't been implemented yet, what?

share|improve this question

closed as off topic by jrg, Marco Ceppi Dec 19 '11 at 15:52

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

2  
This is a bug. Report a bug against metacity on launchpad. –  RolandiXor Dec 13 '11 at 18:34
    
This question should instead be filed as a bug report, thanks! Instructions here. –  jrg Dec 19 '11 at 15:28

2 Answers 2

Unfortunately this is a bug, so there's not much you can do about that other then filing a bug report. But, you can enable the Super(Window Key) + Tab switcher which does the same thing, switches between applications. I will show you how to enable the Super Key + Tab switcher in Ubuntu 11.10.

1. Open the Ubuntu Software Center. Software Center

2. In the search box in the upper right hand corner, type in "Compiz Config Settings Manager". Click on the result for the program, then click install. enter image description here

3. Enter your password when prompted, then press Enter.

4. Once the application has finished installing, open it by pressing the Super key, searching for "Compiz Config Settings Manager", and clicking the result for the program. You will see a window like the following: enter image description here

5. Click "Ring Switcher",Then click check the checkbox to enable the plugin. Close CCSM, then press Super + Tab.

6. Have fun with your new switcher!

enter image description here

share|improve this answer
    
... but unity 2D doesnt use compiz and hence doesnt use ccsm... –  fossfreedom Dec 14 '11 at 14:05
    
Yes... why is he using Unity 2D? Could this be a bug in Unity 2D? –  William Dec 14 '11 at 14:25
    
probably a bug - but the comment has already been made by roland (see the comments just below the question). Dont know why the OP is using Unity2D - but the question is definitely about unity2d not unity+compiz... –  fossfreedom Dec 14 '11 at 14:28
    
I know, I saw the comment. For now, this seems that this is all the OP can do, switch to Unity 3D if it kills him/her, unless there's some reason that he/she can't... –  William Dec 14 '11 at 14:29
1  
To enable compiz in Unity 2D, see this question: askubuntu.com/questions/68711/… –  William Dec 14 '11 at 17:54

For some reason, my answer was converted into a comment. However, I will answer your edit.

The jiggling behaviour is intended to indicate that an application needs your attention, but is not in focus. This is how it works in Unity 3D, and, when everything is in working order, in Unity 2D as well. Probably what is happening is that the application is being given "focus" but not being raised.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.