Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Chrome became slow. Why is that? Firefox is much faster in Ubuntu, but I prefer Chrome, because it gives more "space". Thank you.

share|improve this question
    
There's a Firefox Extension that makes Firefox use less vertical space. –  Uri Herrera Nov 30 '11 at 5:36
1  
Google chrome is slow.. Chromium isn't. What are u using ?? –  Bhargav Nov 30 '11 at 5:48
add comment

3 Answers

up vote 13 down vote accepted

It's not clear if this is a fresh install with a new profile. But it can happen that any browser's performance can degrade over time for various reasons: for example, conflicting extensions or some file being corrupted in one's profile.

First you could try creating a new "profile": with Chrome not running, simply rename the folder that has your details: home/yourname/.config/google-chrome/Default to something else. When you restart Chrome, it will create a new Default. Mostly, this solves most problems. For more details, consult the Linux section in Create a new browser user profile.

(If you have valuable bookmarks, you could export them as html before creating the new profile and import them later via Chrome's Bookmark Manager.)

If the browser performs well with the new profile, it could point to an issue with extensions you had installed. Some ad block extensions are known to affect performance, at least on some pages. If it's a problem with a single extension, all can be disabled and enabled one by one to see when performance degrades. You can get at your extensions by clicking on Customize and Control Google Chrome, Tools, Extensions or by entering chrome://extensions in the address bar and hitting enter.

You can also clear cache, cookies, and browsing history by pressing Ctrl + Shift + Delete together and making appropriate choices.

If you provide more details, someone may have specific guidance.

share|improve this answer
add comment

i think if you remove browser history and try to reinstal, it will work quite a bit faster... dit the trick for me :)

share|improve this answer
1  
Can you explain how? –  Oli Dec 1 '11 at 5:01
add comment

use click and clean extension. It clears all cache during exit.

share|improve this answer
1  
Why an extension you can do that from the preferences menu... –  Uri Herrera Nov 30 '11 at 18:39
1  
Also, can you edit this to provide more information about how to obtain and use that extension, perhaps including screenshots as well as descriptive text? –  Eliah Kagan Sep 6 '12 at 13:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.