Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a problem when I use the mplayer to play *.wmv file on my ubuntu11.10. There are some error messages here. Could anyone can help me solve this problem. I use some keyword to search in Gooele, but I can't find the answer. Thank you.

Playing testmovie.wmv.
ASF file format detected.
[asfheader] Audio stream found, -aid 1
[asfheader] Video stream found, -vid 2
VIDEO:  [WMV3]  1280x720  24bpp  1000.000 fps  4000.0 kbps (488.3 kbyte/s)
Load subtitles in ./
open: No such file or directory
[    MGA] Couldn't open: /dev/mga_vid
open: No such file or directory
[MGA] Couldn't open: /dev/mga_vid
[VO_TDFXFB] Can't open /dev/fb0: Permission denied.
[VO_3DFX] Unable to open /dev/3dfx.
[vdpau] Error when calling vdp_device_create_x11: 1
==========================================================================
Opening video decoder: [dmo] DMO video codecs
DMO dll supports VO Optimizations 0 1
DMO dll might use previous sample when requested
MPlayer interrupted by signal 11 in module: init_video_codec

I am using xv as my video driver.

share|improve this question
    
what video driver are you using? What are the specs of your system? –  Micro Nov 30 '11 at 3:34
    
I use the xv as my video driver. –  Jimmy Nov 30 '11 at 6:47
    
Repo mplayer packages will default to a -vo vdpau unless specified otherwise, either in the cli or thru ~/.mplayer/config. Please try mplayer -vo xv /path/to/file.wmv. If need be run mplayer in verbose (mplayer -v -vo xv /path/to/file.wmv) & paste complete terminal output here paste.ubuntu.com –  doug Nov 30 '11 at 18:17

2 Answers 2

up vote 1 down vote accepted

Playing testmovie.wmv.

ASF file format detected.

Try using VLC Player. It plays almost all media files without any problem.

ASF is a container for WMA, WMV and MPEG4 file formats, and VLC helps in encoding and decoding this so that the file plays seamlessly on your system.

VLC and ASF File Format

The most relevant part of this page being the line on top, saying :

VLC can encode and decode this container.

share|improve this answer
    
Thanks for your reply, what if I just want to know why caused this problem. I tried VLC before, but I think mplayer is better than it. –  Jimmy Nov 30 '11 at 6:49
    
I'm not too sure if this will work for you, but there's no harm in trying. go to Preferences -> Video, and if possible, change from xv to gl. –  Ambar Nov 30 '11 at 11:39
    
I will try later. BTW, I download VLC and found that when I use VLC to play the *.rmvb file, it's seems a little lag. I mean that the act of video seems not smoothly as using mplayer. Do you have the same problem ? –  Jimmy Dec 2 '11 at 8:15

This has been listed as a bug on Launchpad #664848 against the medibuntu package.

Try mplayer -vc ffwmv3 /path/to/yourfile and see if it resolves your problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.