Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Whenever I come back from suspend, the fan spins at full speed for about 2 minutes before it clams down. It will do this regardless of load on the cpu. And the laptop just came back from a (potentially long) suspend so it isn't hot. At all.

After two minutes or so, the fan goes back to normal and then responds to load as you would expect.

How can I get it to not do this?

Edit: This is on an hp pavilion dv6000

share|improve this question
up vote 1 down vote accepted

There is properly only one way... cut the wire feeding power to the fan.

It is not Ubuntu who starts that fan but your BIOS/Mainboard, you may be able to do some tweaking in your BIOS but i doubt it will work for the out of suspend time.

share|improve this answer
Unfortunately it looks like this is the best answer. I looked in the BIOS and didn't find anything to fix it. The BIOS is very limited on this laptop. Oh well I guess. :( – gregghz Oct 22 '10 at 17:07

The original answer is not satisfactory.

More particularly, you may be able to use pwmconfig from the fancontrol package to have more fine-grained control over your fans. Success does vary, though. Try at your own risk -- if you do something wrong you can potentially halt your CPU fan.

share|improve this answer
Thanks for the answer, unfortunately I can't check the results any longer since I no longer have that laptop and I haven't had the issue since. If anyone else can confirm that this is helpful, I'd be willing to change the accepted answer though. – gregghz Jun 12 '12 at 13:18
It's definitely not a solution for everyone. But it's an option. :) – SKhan Jun 12 '12 at 14:46

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.