Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Only front right and left speaker work, and my 5.1 card, is recognized by Ubuntu 10.10, but I have no option for 5.1 in the profile combo Sound -> Hardware

I have tried default-sample-channels = 6 without success.

This is lshw output:

*-multimedia
description: Multimedia audio controller
product: VT1720/24 [Envy24PT/HT] PCI Multi-Channel Audio Controller
vendor: VIA Technologies Inc.
physical id: 8
bus info: pci@0000:00:08.0
version: 01
width: 32 bits
clock: 33MHz
capabilities: pm bus_master cap_list
configuration: driver=ICE1724 latency=32
resources: irq:17 ioport:f800(size=32) ioport:f400(size=128)

I have searched up and down for a solution with no luck

Found something else, sound comes out from 3 jacks but they all have the same left and right channel. Also one of the jacks is supposed to be line-in

share|improve this question

3 Answers 3

Did you try unmuting the Rear, Center and LFE using the advanced volume or alsamixer ?

In Ubuntu the only applications that I know to be able to use 5.1 channels are:

Alsa - driver - needs to be unmuted

Amarok - needs to be configured (in graphical options)

Pulseaudio - mixer - needs to be configured (edit a text file in root)

Totem - needs to be configured - (in graphical options)

speaker-test - perfect

Alsa is automatically configured for 5.1 channels - test this with (after unmuting):

speaker-test -Dplug:surround51 -c6 -l2

where "-c6" means six channels, and "-l2" means run the test twice.

To test pulseaudio, open Totem or Amarok configured to play a DTS file and open:

pavumeter

Watch and see if the sounds are distinct on every channel.

share|improve this answer
    
Yes I did. When using speaker-test only front and rear worked. –  Nachito Oct 28 '10 at 18:15
    
Pulseaudio has some other options in the configuration file regarding center and LFE/subwoofer. Try some combinations. –  iugamarian Oct 28 '10 at 22:44
    
Also to fix the same left and right channel try to disable all checks that have the word "mixer" in their name in alsamixer (or the advanced control settings - Options - Show mixer - Uncheck them). –  iugamarian Oct 28 '10 at 22:55

I have a problem with this soundcard, only the right channel works with boths (speakers & headphones). My speakers are not for 5.1. :S

share|improve this answer
    
Are you using 10.10? In my case both channels worked. The problem was that 3 jacks have right an left –  Nachito Nov 13 '10 at 2:10

Try updating alsa It will recognize your sound card,or try your vendors web site and get support for your matter. If given, use their drivers and install carefully after reading the READ ME! (you will make your sounds completely gone if you do something wrong there-Self experience)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.