Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In 11.11 keyboard settings there are Move window to workspace N options (N is the workspace number). But they do not work.

Is there a way to bind key for moving window to a specific workspace/viewport?

share|improve this question
    
I know this isn't exactly what you want, but I use the keyboard to move windows between workspaces all the time, so this could be a useful workaround. I press Alt-Space (which brings up the window menu), press W (Move to another Workspace), and then select the workspace number (1, 2, 3, ...) –  Eric Lambart Jul 1 at 16:55
add comment

2 Answers 2

That's either a bug or a consequence of a tweaked environment.

To verify the keyboard shortcut visit the gear in the upper right hand corner, select system settings -> keyboard -> shortcuts -> navigation. Move Window one workspace to the [direction] should be defined. If it is and you're still having problems then try resetting unity to defaults.

To reset unity to it's defaults: unity --reset:

Once that's done: CTRL+ALT+SHIFT [ARROW] will take the active window and place it on the desktop you're pointing to. CTRL+ALT [ARROW] just switches the current desktop.

UPDATE:

After clarifying the bug with the user. I found out that this is actually a known bug.

It looks like it's getting lost in the wishlist status. I would recommend filing a new bug to bring fresh attention to it. I agree that it's a bug. If it isn't an option then it should be removed from Navigation shortcuts to begin with. I think I will to, this would be very useful.

share|improve this answer
2  
I am talking about moving window to a specific workspace. Not left/right/up/down. See Navigation -> Move window to workspace 1. –  Iakov Davydov Nov 29 '11 at 15:45
    
I filed my bug, you should too. I noticed in playing these shortcuts that the other set of disabled shortcuts "Switch to workspace X" does work. –  ppetraki Nov 29 '11 at 19:38
    
Thanks. I have reported the bug. –  Iakov Davydov Nov 30 '11 at 10:00
    
I don't suppose there's any work-around, either? –  Brian White Nov 28 '13 at 22:27
    
@BrianWhite: there is, with CCSM, see my answer. –  Gauthier Jun 18 at 7:38
add comment

This is still not working in the original Settings in 14.04.

However you can make it work if you install CompizConfig Settings Manager (CCSM), activate the plugin "Put", and bind its settings in the section "Put to arbitrary viewport".

The bindings may look a little strange (<Shift><Control><Alt>1 shows up as <Shift><Control><Alt>exclam), but it's working for me.

Note that when you move the window to another viewport, the current viewport in view changes as well (e.g. putting a window from viewport 1 to viewport 2 might make you switch your view to viewport 2). To avoid this, go to CCSM->Put->Misc.Options, and tick "Unfocus Window".

I use CCSM->Put to move windows to arbitrary viewports without changing current view, and the Ubuntu Settings with arrows to move windows to adjacents viewports and moving the view (following the window) at the same time.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.