Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I connect to my Samsung Galaxy S2 by USB from my Ubuntu 11.10 computer. It was working fine up until a few days ago.

Now, for reasons I can't determine, whenever I try to copy any files using the file manager (Nautilus), the transfer always stops at around 10 to 15% done, and then it hangs. The only way to kill the process is to disconnect the USB physically.

I thought maybe this was a problem with the SD card having an error, so I reformatted it, but that hasn't helped. Also, the same thing happens with the Galaxy's internal USB storage as well.

This seems to be an Ubuntu problem, as I tested transferring files on a Windows computer and it went through without any issues.

share|improve this question

migrated from android.stackexchange.com Nov 29 '11 at 13:58

This question came from our site for enthusiasts and power users of the Android operating system.

closed as too localized by Marco Ceppi Feb 6 '12 at 6:09

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
I assume you have enough free space? –  Matthew Read Nov 29 '11 at 6:07
    
Tons of free space. :) –  Dave M G Nov 29 '11 at 6:43
    
I flagged this for moderator attention, as it seems the issue has magically gone away, probably the result of upgrades or some other change. –  Dave M G Feb 6 '12 at 5:46
add comment

1 Answer 1

Is your phone perhaps going into low power mode / screen lock? The native Ubuntu drivers may not be keeping it awake over USB.

It works fine for me on 10.04, but I also have ADB installed which may be making a difference. Have you tried installing ADB? (the Eclipse plugin is purely for devs, I don't have it installed myself)

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.