Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hi all I'm running kubuntu 11.10 and I'm trying to run ubuntu one, but I get this error. What am I doing wrong?

maurizio@maurizio-desktop:~$ ubuntuone-installer  
Traceback (most recent call last):   
File "/usr/bin/ubuntuone-installer", line 39, in <module>
dialog = Window()   
File "/usr/lib/python2.7/dist-packages/ubuntuone-installer/ubuntuone/installer/gui.py", line 105, in __init__
    _(u'Discover the freedom of your personal cloud'))) 
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 16: ordinal not in range(128)

Thanks

share|improve this question

2 Answers 2

up vote 2 down vote accepted

I suggest first trying like this:

LC_ALL=C ubuntuone-installer

But if that does not work , according to this bug there is a workaround for this issue.

First, install the needed package:

sudo apt-get install ubuntuone-control-panel

And then configure you account.

ubuntuone-control-panel-gtk

If that does not work, just uninstall all the Ubuntu One packages and do this again.

share|improve this answer
    
Thanks a lot this solved my problem. Any idea why I was having an issue in the first place^ –  MaurizioPz Nov 29 '11 at 17:37
    
I think this is a problem with Python and your system language. –  heartsmagic Nov 29 '11 at 17:57
sudo apt-get remove ubuntuone-control-panel-gtk
sudo apt-get install ubuntuone-control-panel-gtk

remove/install did it for me, now the ubuntu one icon in system settings will launch.

I'm running english/new zealand. Is this broken for all non-american english speakers?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.