Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

At the login screen of my Ubuntu box, I select Ubuntu under the cog menu, but it loads the 2D version instead of the 3D version.

I'm running:

  • Asus P5Q Pro
  • Intel Core 2 Quad Q6600 @ 2.40GHz x4
  • GeForce 9600GT (1024MB)
  • 32-bit OS
  • 4x 1GB DDR2 RAM Modules (although BIOS only shows I'm using ~3GB)

Is this setup not capable of running Unity 3D? I understand that it won't install it if it's not supported!

unity_support_test output:

penGL vendor string:   NVIDIA Corporation
OpenGL renderer string: GeForce 9600 GT/PCI/SSE2
OpenGL version string:  3.3.0 NVIDIA 290.10

Not software rendered:    yes
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       yes

glxinfo output after driver reinstall:

direct rendering: Yes
    GL_NV_path_rendering, GL_NV_pixel_data_range, GL_NV_point_sprite, 

direct rendering: Yes
    GL_NV_path_rendering, GL_NV_pixel_data_range, GL_NV_point_sprite, 
share|improve this question
    
run this comand and check if your graphics can support unity or not /usr/lib/nux/unity_support_test -p. –  sagarchalise Nov 29 '11 at 11:01
    
I get a 'Segmentation fault' when I run that command.... –  neildeadman Nov 29 '11 at 11:21
    
What is the output of this: sudo jockey-text --list –  heartsmagic Nov 29 '11 at 11:34
1  
usually the problems occur when openGL support does not work. Please check the output of glxinfo | grep rendering - there should appear "direct rendering: yes" - further you can test opengl-support with glxgears. Then you should see rotating gears. If one of this does not wort, reinstall your graphics driver. I suggest to install the proprietary Nvidia driver as I described here: askubuntu.com/questions/80121/… –  Michael K Nov 29 '11 at 11:45
    
@heartsmagic output is: kmod:nvidia_current_updates - NVIDIA binary Xorg driver, kernel module and VDPAU library (Proprietary, Disabled, Not in use) kmod:nvidia_173 - NVIDIA binary Xorg driver, kernel module and VDPAU library (Proprietary, Disabled, Not in use) kmod:nvidia_173_updates - NVIDIA binary Xorg driver, kernel module and VDPAU library (Proprietary, Disabled, Not in use) kmod:nvidia_current - nvidia_current (Proprietary, Enabled, Not in use) -- I tried to install nvidia latest driver and now have x server issues! –  neildeadman Nov 29 '11 at 12:42
show 9 more comments

1 Answer

Answer from a comment to the question:

Usually the problems occur when openGL support does not work. Please check the output of glxinfo | grep rendering - there should appear direct rendering: yes - further you can test opengl-support with glxgears. Then you should see rotating gears. If one of this does not wort, reinstall your graphics driver. I suggest to install the proprietary Nvidia driver as I described here in this question

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.