Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running on a clean install of 10.10 Server edition and have alsa-base, alsa-tools, alsa-utils, alsaplayer, and alsa-firmware-loader installed. At one point I installed pulseaudio, but I have since removed it.

I've tried the following

lspci | grep audio
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)
01:06.0 Multimedia audio controller: Creative Labs [SB Live! Value] EMU10k1X

aplay -l
aplay: device_list:235: no soundcards found...

alsamixer
can not open mixer: No such file or directory

When I search for modules with

find /lib/modules/`uname -r` | grep snd

I do get a list of modules

I'm not very experienced with alsa setup, so I'm not sure where to go from here

share|improve this question
    
Is there any info regarding sound in the output from these commands: lsmod and dmesg (lsmod lists modules/drivers loaded, and dmesg displays debug messages from the system kernel. –  Source Lab Oct 19 '10 at 23:10
add comment

2 Answers

Adding myself to the user group "audio" solved my problem. I determined this was the problem when

sudo aplay -l

returned results about the audio card, but

aplay -l

returned nothing.

Command to run:

sudo useradd -aG audio your_username

You have to log out to get the change working.

share|improve this answer
add comment

The first thing to check is that the snd modules are being loaded, please check and report on the output of this command:

lsmod | grep snd

If that was the problem, next you should check the audio device available from those with this command:

cat /proc/asound/cards

If adding the sound modules doesn't work, then consider checking what hardware you have available with this command:

lspci | grep Audio

More information about debugging sound issues can be found here:

https://wiki.ubuntu.com/DebuggingSoundProblems

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.