Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

enter image description here

I would like to show the date in the bar up the top there (next to the time). I can not see any obvious way to enable this.

share|improve this question
add comment

4 Answers 4

up vote 21 down vote accepted

As a regular user run this in a terminal when using gnome-shell:

gsettings set org.gnome.desktop.interface clock-show-date true

For 11.10, use this instead:

gsettings set org.gnome.shell.clock show-date true

Hope this is what you're looking for!

share|improve this answer
2  
In Ubuntu 12.04, this setting no longer seems to apply. Instead, you can click on the clock, go to Time & Date Settings, select the Clock tab, and check options there to show Weekday or Date and Month in the clock. It's a more obvious place to put these settings, but I had already learned the (now broken) gnome-tweak-tool or gsettings approach. –  Shimon Rura Sep 22 '12 at 12:51
    
In Ubuntu 13.04 Gnome 2, use com.canonical.indicator.datetime. See askubuntu.com/questions/129985/… –  Rafael Xavier Sep 16 '13 at 17:31
    
also works on Debian (and also unsing dconf-editor) –  William Dec 11 '13 at 14:01
1  
For Ubuntu 12.04: gsettings set com.canonical.indicator.datetime show-date true –  James May 23 at 14:12
add comment

Not an ubuntu user but, if you install gnome-tweak-tool, you'll have a nice gui to adjust things like this.

I'm guessing your install from repo might be something like:

apt-get gnome-tweak-tool

share|improve this answer
    
Gnome Tweak is indeed a necessity for making 11.10 usable. Also, the date setting is under Shell->Show date in clock. –  Cerin Mar 11 '12 at 18:57
add comment

For most people, the command line option supplied by itnet7 is probably the quickest.

However, if you like a GUI, you can use the tool dconf-editor. Simply run "dconf-editor". It is included by default with many distributions, but should be in the repositories if it isn't installed.

One you've started dconf-editor, follow the tree of settings to: org-gnome-shell-clock

and change the "Show date" checkbox (as shown below), and the seconds display for the clock too, if you like that sort of thing.

dconf-editor settng for panel clock

Edit: This has changed slightly for Ubuntu 12.10. Using dconf-editor, date & time settings are now located under com-canonical-indicator-appmenu-datetime.

share|improve this answer
add comment

In Ubuntu 12.04 you click on the time in the bar then:

  • Click on Time & Settings
  • Click the Clock tab
  • In the clock, show:
    • Check Weekday and/or Date and month
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.