Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to set a static IP address for my server, but what ifconfig is returning is leaving me a little bit confused:

If I run the command

ifconfig

I see that wlan0 is the only returned option that is sending and receiving packets besides the local loopback. This should be, as I am using a PCI adapter in my desktop in order to access the internet wirelessly. (I know this is not the most efficient way - learning purposes)

The problem is, I do not know how to configure /etc/network/interfaces with a wlan0 address; no matter where I look on the internet, they all say to use eth0, but I am not using Ethernet.

Any help is greatly appreciated.

share|improve this question
    
I see things like help.ubuntu.com/10.04/serverguide/C/network-configuration.html but this really is not wlan0 as far as I can see. –  nmagerko Nov 28 '11 at 22:04

1 Answer 1

up vote 2 down vote accepted

eth0 and wlan0 are interface names but the general options for them should be the same, if you want to configure your wlan0 interface for static IP you can do so using the same terminology of the information you see in the internet referring to eth0.

They are just names for the interfaces, nothing else. The name of your wireless interface in your system is wlan0 use that while editing it but the rest (IP address, subnet masks, broadcasts...) are common options for any interface.

If you are not so confident in editing the interfaces by hand you can also use nm-connection-editor to edit your wireless (and much more).

Open a terminal and typo gksudo nm-connection-editor or the same after you pressed Alt+F2 in your desktop.

share|improve this answer
    
Saw that you referred to server so probably you are not running a desktop so the last part of the answer will not do for you, still its useful and can be used for ppl running servers with a desktop. –  Bruno Pereira Nov 28 '11 at 22:08
    
gksudo nm-connection-editor doesn't do anything. –  B Seven Jul 8 '12 at 1:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.