Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Somehow the default sort order in open dialogues has changed to be sorted by Modified. It's changed in all programs, not just a specific one.

This forces me to reach for the mouse and click the Name column every time I open a file (maybe I'm nitpicking but this gets annoying...).

How can I set the default sort order back to Name? Nautilus sorts by name by default when I browse into folders.

share|improve this question
add comment

2 Answers

Run dconf-editor (I assume that you've already installed dconf-tools package),
then navigate to org->gtk->settings->file-chooser and set value of key sort-column to name
or simple click on "Set to Default" button

dconf-editor

share|improve this answer
2  
Thanks for the answer, it seems that should work but my sort-column is already set to 'name', and I hit set to default just to be sure. When I goto open a file it's still sorting by modified (I've tried several programs). –  Sheldno Nov 29 '11 at 14:33
    
I have the opposite problem - it's sorted by name, and I'd like it to be sorted by modified. I tried changing "sort-column" to "modified", but no luck. Any ideas? –  begtognen Jul 15 '13 at 12:09
add comment

If the above dconf-editor answer doesn't work for you, try the method described in this answer. Edit ~/.config/gtk-2.0/gtkfilechooser.ini. Look for the section beginning with [Filechooser Settings] and change SortColumn=modified to SortColumn=name.

share|improve this answer
add comment

protected by Community Apr 10 '12 at 19:01

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.