Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed my new computer today with 11.10 (i5-2500K, ASUS P8Z68-V LX, using the onboard graphic processor). After updating everything went fine but then I tried to go to StandBy-mode. This crashed the computer so I had to cold-reset it. Now the display manager doesn't come up on boot anymore. I need to login into a shell and type sudo service lightdm restart. After that the login comes up normally.

The Xorg.0.log says, that there were no monitors found

I have not changed the default display manager to gdm and then back. /etc/X11/default-display-manager says "/usr/sbin/lightdm"

thanks in advance

share|improve this question
    
Hi, have you tested reinstalling the x? –  Christian Vielma Nov 28 '11 at 18:38
    
after 'sudo aptitude reinstall xorg' the login came directly after the reboot but then i had to enter my password twice. when i tried to shutdown the computer froze. on the next boot, same as before. today i updated the kernel. now only one display shows something. ive got the same problem on my other pc. same mainboard, same cpu but there is an amd radeon hd 6870 installed. the xorg log sais something about missing fglrx but i am using the radeon driver and after restarting lightdm the login comes. –  Ewald Nov 29 '11 at 6:40
    
Now i tried to compile the intel driver from 'intellinuxgraphics.org' myself. at the next start the login appeared. after rebooting it didn't anymore. -> same as before. the '/var/log/Xorg.0.log': pastebin.com/RfUUFQvR I have an Intel X25-M SSD in my computer. Startup takes only a few seconds. Could the problem have todo with conflicting startup processes? –  Ewald Nov 29 '11 at 8:17

1 Answer 1

Usually this kind of problem are caused by a bad behaviour of xrandr or a bad configuration of X or a bad configuration of the local scripts like the scripts that you have hidden in your home folder ~.

Try to investigate xrandr, i know that this is probably not a complete answer but do not expect to solve problems like this one with a tip or a trick in 1 row of code, especially with driver like the ones from Intel that are not so famous for their performance and reliability.

What i can say is that if your X is properly installed its own configuration are mainly managed through xrandr and after xrandr comes the files under /etc/ and the local scripts in your home folder.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.