Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a friend wanting to install Ubuntu 10.10 as a dual-boot with Windows through Wubi. Unfortunately, he has a wireless card with a Broadcom chipset, and needs to install the drivers. There is no other way for him to connect to the internet; he cannot connect via Ethernet or another Wi-Fi dongle/card.

I generated a Synaptic download script for what I think are the appropriate packages, and he downloaded the .debs to \wifi\packages from Windows. He then ran these commands:

kieran@ubuntu:~$ cd /host/wifi
kieran@ubuntu:/host/wifi$ sudo dpkg -i packages/*.deb
[sudo] password for kieran: 
(Reading database ... 120178 files and directories currently installed.)
Preparing to replace bcmwl-kernel-source 5.60.48.36+bdcom-0ubuntu3 (using .../bcmwl-kernel-source_5.60.48.36+bdcom-0ubuntu3_i386.deb) ...
Removing all DKMS Modules
Done.
Unpacking replacement bcmwl-kernel-source ...
Preparing to replace broadcom-sta-common 5.10.91.9.3-3 (using .../broadcom-sta-common_5.10.91.9.3-3_all.deb) ...
Unpacking replacement broadcom-sta-common ...
Preparing to replace broadcom-sta-source 5.10.91.9.3-3 (using .../broadcom-sta-source_5.10.91.9.3-3_all.deb) ...
Unpacking replacement broadcom-sta-source ...
Preparing to replace build-essential 11.4build1 (using .../build-essential_11.4build1_i386.deb) ...
Unpacking replacement build-essential ...
Preparing to replace cvs 1:1.12.13-12ubuntu1 (using .../cvs_1.12.13-12ubuntu1_i386.deb) ...
Unpacking replacement cvs ...
Preparing to replace debhelper 7.4.15ubuntu1 (using .../debhelper_7.4.15ubuntu1_all.deb) ...
Unpacking replacement debhelper ...
Preparing to replace diffstat 1.47-1build1 (using .../diffstat_1.47-1build1_i386.deb) ...
Unpacking replacement diffstat ...
Preparing to replace dkms 2.1.1.2-2fakesync1 (using .../dkms_2.1.1.2-2fakesync1_all.deb) ...
Unpacking replacement dkms ...
Preparing to replace dpkg-dev 1.15.5.6ubuntu4.3 (using .../dpkg-dev_1.15.5.6ubuntu4.3_all.deb) ...
Unpacking replacement dpkg-dev ...
Preparing to replace fakeroot 1.14.4-1ubuntu1 (using .../fakeroot_1.14.4-1ubuntu1_i386.deb) ...
Unpacking replacement fakeroot ...
Preparing to replace g++ 4:4.4.3-1ubuntu1 (using .../g++_4.4.3-1ubuntu1_i386.deb) ...
Unpacking replacement g++ ...
Preparing to replace g++-4.4 4.4.3-4ubuntu5 (using .../g++-4.4_4.4.3-4ubuntu5_i386.deb) ...
Unpacking replacement g++-4.4 ...
Preparing to replace gettext 0.17-8ubuntu3 (using .../gettext_0.17-8ubuntu3_i386.deb) ...
Unpacking replacement gettext ...
Preparing to replace html2text 1.3.2a-14build1 (using .../html2text_1.3.2a-14build1_i386.deb) ...
Unpacking replacement html2text ...
Preparing to replace intltool-debian 0.35.0+20060710.1 (using .../intltool-debian_0.35.0+20060710.1_all.deb) ...
Unpacking replacement intltool-debian ...
Preparing to replace libmail-sendmail-perl 0.79.16-1 (using .../libmail-sendmail-perl_0.79.16-1_all.deb) ...
Unpacking replacement libmail-sendmail-perl ...
Preparing to replace libstdc++6-4.4-dev 4.4.3-4ubuntu5 (using .../libstdc++6-4.4-dev_4.4.3-4ubuntu5_i386.deb) ...
Unpacking replacement libstdc++6-4.4-dev ...
Preparing to replace libsys-hostname-long-perl 1.4-2 (using .../libsys-hostname-long-perl_1.4-2_all.deb) ...
Unpacking replacement libsys-hostname-long-perl ...
Preparing to replace patch 2.6-2ubuntu1 (using .../patch_2.6-2ubuntu1_i386.deb) ...
Unpacking replacement patch ...
Preparing to replace po-debconf 1.0.16 (using .../po-debconf_1.0.16_all.deb) ...
Unpacking replacement po-debconf ...
Preparing to replace quilt 0.48-5 (using packages/quilt_0.48-5_all.deb) ...
Unpacking replacement quilt ...
Setting up broadcom-sta-common (5.10.91.9.3-3) ...
Setting up cvs (1:1.12.13-12ubuntu1) ...
Ignoring install-info called from maintainer script
The package cvs should be rebuilt with new debhelper to get trigger support
Ignoring install-info called from maintainer script
The package cvs should be rebuilt with new debhelper to get trigger support
Setting up diffstat (1.47-1build1) ...
Setting up dkms (2.1.1.2-2fakesync1) ...
dpkg: dependency problems prevent configuration of dpkg-dev:
 dpkg-dev depends on xz-utils; however:
  Package xz-utils is not configured yet.
dpkg: error processing dpkg-dev (--install):
 dependency problems - leaving unconfigured
Setting up fakeroot (1.14.4-1ubuntu1) ...
dpkg: dependency problems prevent configuration of g++-4.4:
 g++-4.4 depends on gcc-4.4-base (= 4.4.3-4ubuntu5); however:
  Version of gcc-4.4-base on system is 4.4.4-14ubuntu5.
 g++-4.4 depends on gcc-4.4 (= 4.4.3-4ubuntu5); however:
  Version of gcc-4.4 on system is 4.4.4-14ubuntu5.
 g++-4.4 depends on libmpfr1ldbl; however:
  Package libmpfr1ldbl is not installed.
dpkg: error processing g++-4.4 (--install):
 dependency problems - leaving unconfigured
Setting up gettext (0.17-8ubuntu3) ...
Setting up html2text (1.3.2a-14build1) ...
dpkg: dependency problems prevent configuration of libstdc++6-4.4-dev:
 libstdc++6-4.4-dev depends on gcc-4.4-base (= 4.4.3-4ubuntu5); however:
  Version of gcc-4.4-base on system is 4.4.4-14ubuntu5.
 libstdc++6-4.4-dev depends on g++-4.4 (= 4.4.3-4ubuntu5); however:
  Package g++-4.4 is not configured yet.
dpkg: error processing libstdc++6-4.4-dev (--install):
 dependency problems - leaving unconfigured
Setting up libsys-hostname-long-perl (1.4-2) ...
Setting up patch (2.6-2ubuntu1) ...

dpkg: dependency problems prevent configuration of build-essential:
 build-essential depends on dpkg-dev (>= 1.13.5); however:
  Package dpkg-dev is not configured yet.

dpkg: error processing build-essential (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of debhelper:
 debhelper depends on dpkg-dev (>= 1.14.19); however:
  Package dpkg-dev is not configured yet.
dpkg: error processing debhelper (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of g++:
 g++ depends on g++-4.4 (>= 4.4.3-1); however:
  Package g++-4.4 is not configured yet.
dpkg: error processing g++ (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of broadcom-sta-source:
 broadcom-sta-source depends on debhelper (>= 7); however:
  Package debhelper is not configured yet.
dpkg: error processing broadcom-sta-source (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db ...
Setting up bcmwl-kernel-source (5.60.48.36+bdcom-0ubuntu3) ...
Loading new bcmwl-5.60.48.36+bdcom DKMS files...
First Installation: checking all kernels...
Building only for 2.6.35-22-generic
Building for architecture i686
Building initial module for 2.6.35-22-generic

Error! Bad return status for module build on kernel: 2.6.35-22-generic (i686)
Consult the make.log in the build directory
/var/lib/dkms/bcmwl/5.60.48.36+bdcom/build/ for more information.
Traceback (most recent call last):
  File "/usr/share/apport/package-hooks/dkms.py", line 57, in 
    report.write(open(apport.fileutils.make_report_path(report), 'w'))
IOError: [Errno 2] No such file or directory: '/var/crash/bcmwl-kernel-source.0.crash'
dpkg: error processing bcmwl-kernel-source (--install):
 subprocess installed post-installation script returned error exit status 10
Setting up libmail-sendmail-perl (0.79.16-1) ...
Processing triggers for install-info ...
Setting up intltool-debian (0.35.0+20060710.1) ...
Setting up po-debconf (1.0.16) ...
Setting up quilt (0.48-5) ...
Processing triggers for doc-base ...
Processing 4 changed doc-base file(s)...
Registering documents with scrollkeeper...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Errors were encountered while processing:
 dpkg-dev
 g++-4.4
 libstdc++6-4.4-dev
 build-essential
 debhelper
 g++
 broadcom-sta-source
 bcmwl-kernel-source

The xz-utils package would not install separately either. Is there any way to solve the dependency problem, or an easier way to configure the wireless card?

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

From the line libstdc++6-4.4-dev depends on gcc-4.4-base (= 4.4.3-4ubuntu5); however: Version of gcc-4.4-base on system is 4.4.4-14ubuntu5. I am 99% confident you are trying to install 10.04 (Lucid) packages on a 10.10 (Maverick) system.

This is almost always a bad idea.

I'm not sure about the details of your Synaptic download script but I hope you can use this information to modify the script to work.

share|improve this answer
    
D'oh. It turns out my install (where I used Synaptic to generate the download script) is 10.04, rather than 10.10. Thanks! :) –  Lucas Jones Oct 19 '10 at 20:26
add comment

use dkpg adding --ignore-depends

share|improve this answer
2  
This needs a bit more detail on what to do and what this does. –  RolandiXor Nov 17 '11 at 18:15
    
Is the syntax broken here? –  landroni Feb 4 at 7:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.