Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am unable to get the weather notification that comes with the clock applet to work.

I have it set to Ottawa, Canada. What seems to be the problem.

Canada jokes to the minimum please :)

Please and thank you.

share|improve this question
    
Do you get any error messages? –  txwikinger Aug 4 '10 at 20:36
    
Could you be more specific? What is it that doesn't work? Exactly what is it that you do? –  Tommy Brunn Aug 4 '10 at 20:37
    
btw. no Canada jokes from this end ;) –  txwikinger Aug 4 '10 at 20:46
    
@txwikinger no error message just doesn't show anything but leaves space for the icon though. –  myusuf3 Aug 4 '10 at 20:57
    
ok, bare minimum: did the applet freeze? –  ithkuil Sep 5 '10 at 22:28
add comment

3 Answers 3

up vote 3 down vote accepted

The Canadian location that I have in the Weather tool on my computer includes the province.

When I go to the Choose Location screen and type "Ottawa" I get a suggested entry of "Ottawa, Ontario, Canada". Using the suggested location results in the weather icon beside the placename, but if I enter "Ottawa, Canada" no weather information is displayed.

Try adding a new location and make sure to select the name suggestion that should appear when you type "Ottawa". I have found some quirks with the weather locations on the clock menu, at least on my system. (I have explained them below.)


On my Ubuntu system, in order to get the weather icon I had to actually select the suggested location name rather than typing the full name.

If Ubuntu has not recognized the location the full "text of the "Location Name" field (e.g. "Ottawa, Ontario, Canada") will be displayed. If the location has been recognized the display will shorten that to just "Ottawa". The weather icon only seems to appear when Ubuntu recognizes the name.

Here is what I did:

  1. I went to the Locations tab of the Clock Preferences and added a location named "Ottawa, Canada" with a time zone of "Eastern Time (GMT-5 / GMT-4)".
  2. I then edited the location I just added, and changed the location name to "Ottawa, Ontario, Canada".
  3. Without clicking on the suggested name that popped up, I clicked OK.

At this point the Locations list displayed "Ottawa, Ontario, Canada" without weather.

Finally, I edited the location again, and backspaced some letters to get the suggestion popup to reappear. I selected "Ottawa, Ontario, Canada" from the popup and clicked OK again. Now the Locations listed displayed "Ottawa" with a weather icon.

I even tried copying all of the information from a working location entry (including the latitude and longitude) into a new location. The only way I could get the weather icon was by actually selecting the appropriate name from the suggestion popup.

share|improve this answer
    
no mas! Thanks though. –  myusuf3 Aug 4 '10 at 21:53
    
@garbagecollector I did some experimenting with the clock menu on my system, and updated my answer with more detail. I hope it helps you. –  moberley Aug 5 '10 at 0:56
add comment

You may want to try setting Ottawa airport code (YOW) as weather station. It usually works for me (LEAS, Asturias, Spain) when any other weather stations are down or don't work. Good luck!

share|improve this answer
    
no luck. Thanks though. –  myusuf3 Aug 4 '10 at 21:54
add comment

It could be that it's not getting any data from your local whether station, I guess. Have you tried setting it to a different location - just to see if it works at all?

share|improve this answer
    
same difference. –  myusuf3 Aug 4 '10 at 21:02
    
I have often experienced that after upgrades of weather packages Canadian weather stations did not work anymore. Try one outside Canada. –  txwikinger Aug 4 '10 at 21:02
    
It doesn't work at all. :) –  myusuf3 Aug 4 '10 at 21:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.