Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I enabled the desktop cube and when I restart PC ....on desktop I can't see anything and all panel on desktop are gone and at the time of login when I select ubuntu 2d then it works fine.

share|improve this question
    
Does the Firefox problem occur only when you are attempting to use the Ubuntu session type, but also work fine when you use Ubuntu 2D? (If not, and it always occurs, then it's probably a separate problem which you should edit your question to remove, and post a new, separate question about.) –  Eliah Kagan Nov 28 '11 at 7:00
    
I've edited your question to just deal with the cube problem, please post your firefox question as a new question. –  Jorge Castro Nov 29 '11 at 3:03

1 Answer 1

Login in to Ubuntu 2d

You Have two options to solve this problem

1.

Start ccsm

Check that you have marked ubuntu unity plugin you won't be able to use desktop cubes because unity must have the desktop wall plugin.

It should look like this enter image description here

Log out and you should be able to login in to unity

2.

Reset to default standard

Start ccsm

Go to preferences

enter image description here Reset to default enter image description here

Check if the Ubuntu unity plugin is enabled

enter image description here

Log out and you should be able to login in to unity

share|improve this answer
    
This answer needs more detail to be useful... –  RolandiXor Nov 28 '11 at 16:08
    
@ Roland I hope this is better only a have a dutch install instead of an English one. –  Rens Nov 28 '11 at 19:18
    
no problem! The screenshots are great, because the interface is essentially the same for everyone no matter the language :). –  RolandiXor Nov 28 '11 at 20:00
    
if re-enabling the unity-shell plugin while in unity-2d you'll be set to the Default profile when logging back into ubuntu (unity3d). Better to be using the unity profile. Preferences in ccsm will only work correctly if you have the updated version of compizconfig-python (0.9.5.94-0ubuntu3). Otherwise better to re-enable the unity plugin while in the ubuntu (unity3d) session –  doug Nov 29 '11 at 4:02
    
@doug if you want to change it from 3d you'll have to make in 2d a starter and then go back to 3d start the starter enable unity. Which might be a problem for some tell me if that would be better. This works for me as I had the same problem. –  Rens Nov 29 '11 at 7:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.