Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It acts like it wants to work, but all I get is the bar across the top with "activities", the time, my name, and the background. After that my computer will do nothing else.

I installed it following the directions here, detailing how to install it on Ubuntu (have tried the repository version and the PPA version).

Graphics card information:

$ lspci | grep VGA

00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
share|improve this question
2  
How did you go about installing gnome-shell? Also how did you go about running it? –  fluteflute Oct 19 '10 at 19:14
1  
Graphic card information and anything interesting from the Xorg.log would help as well. –  NightwishFan Oct 19 '10 at 19:17
    
Oddly enough it works on my desktop, which are obviously two completely different computers... So I am guessing that maybe it is a hardware issue on my laptop... –  TheX Oct 19 '10 at 21:51
    
Have you tried running the Unity interface? Seeing as both use Mutter as a window manager (currently) it would be interesting to know if Unity works... –  fluteflute Oct 30 '10 at 7:04
    
@fluteflute I don't think that's correct: Unity shows up as a Compiz plugin. I'm pretty sure it's running Compiz (Fusion) as the window manager. –  Nicholas Flynt Oct 26 '11 at 19:47
show 2 more comments

5 Answers

You can report such bugs by pressing Alt+F2 and then entering ubuntu-bug gnome-shell. This will allow the developers to help improve Ubuntu. (The same procedure is used for any application.) This automatically adds your hardware information to the report.

Note: you need to remove the PPA version, and have the version from the standard repositories installed to do this.

share|improve this answer
add comment

This happens if you delete your hidden ~/.gnome* folder(s) and Gnome does not have what to show.

Solution: start in Ubuntu live cd and copy the hidden ~/.gnome* folder(s) from the cd to your hard drive user folder.

Alternatively copy from the root folder to the user folder.

Then boot from hard-disk and create launchers to recover lost shortcuts.

share|improve this answer
    
This did not work. I did not delete it, and it was present... But I replaced it with the vanilla one anyways... –  TheX Oct 27 '10 at 0:55
add comment

I believe this is probably a hardware issue with your graphics card. Sometimes the shell freezes when mutter doesn't like your graphics driver. Report a bug on the GNOME bugzilla so the developers can possibly find a workaround.

On another note, the technology for GNOME Shell is still a bit immature right now, and mileage will vary. Reporting a bug about your issue should help them to improve it.

share|improve this answer
add comment
up vote 0 down vote accepted

I fixed it by re-installing ubuntu... makes me wonder if I got rid of something it depended on by accident..

share|improve this answer
add comment

Try this, press alt+f2 and type:

gksudo gedit

When gedit opens, open the file "/etc/environment". Paste the following text on a new line:

export CLUTTER_VBLANK=none

Save the file and reboot. This works enabling some clutter related features for me, and I have this exact chipset. Though I will say Gnome Shell works for me by default so.. :/

share|improve this answer
    
As you say yourself, this is unrelated to the problem at hand. –  loevborg Oct 30 '10 at 17:23
    
That makes no sense.. It might very well be a problem. It fixes other clutter related issues for me. –  NightwishFan Oct 30 '10 at 17:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.