Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I receive this error:

unity-place-websearch : Depends: gir1.2-unity-3.0 but it is not installable

Using 11.10, here's how to replicate:

sudo add-apt-repository ppa:cscarney/unity-web-place
sudo apt-get update
sudo apt-get install unity-place-websearch
share|improve this question
    
This is the lens you are talking about, correct? –  WarriorIng64 Nov 28 '11 at 3:24
    
Yes, the web sources lens. –  chaselee Nov 28 '11 at 14:48
add comment

1 Answer 1

The Unity Web Search lens is out of date. It requires gir1.2-unity-3.0 which has been upgraded to gir1.2-unity-4.0 in 11.10. There isn't much of a way around it except for maybe running 11.04 rather than 11.10, updating the package yourself, or just waiting for someone else to update it.

You might be able to change the list of prerequisites for the package to include the newest version of gir1.2-unity, but I wouldn't know how to do that.

share|improve this answer
    
I noticed the dependency was the issue but I doubt it is a dependency in real terms, so I agree, forcing the install should work fine. Also not sure how to force despite dependencies though. I usually just have to force based on architecture :-P –  chaselee Nov 28 '11 at 14:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.