Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My machine shut down unexpectedly today (laptop battery is crap) and when I rebooted it I lost all sound.

I tried to go to Preferences->Sound but it just opens a little window saying "waiting for sound system to respond" and nothing happens. When my computer rebooted it did warn me of some errors in the filesystem after the unexpected shut down, but I let it correct all errors it found. I understand I may need to reinstall some packages, but I don't know which.

System: Dell XPS m1330 Ubuntu 10.10 64bit

Is there anyone out there who can help me? Thanks in advance!

share|improve this question
add comment

2 Answers

You could use this nice script:

http://ubuntuforums.org/showthread.php?p=6589810

It should upgrade your sound drivers to the latest version and uninstall the older ones first.

share|improve this answer
    
That sounds like a hammer solution when he might only need a scalpel. We need more information I think. –  Jorge Castro Oct 19 '10 at 19:35
    
OK, so before I use the "hammer" above, can you direct me to what info would be of value? thanks a lot for the help –  S B Oct 20 '10 at 20:44
add comment
up vote 2 down vote accepted

This question was solved for me on Ubuntu forums 1:0 forums vs. askubuntu :-)

Link to thread: http://ubuntuforums.org/showthread.php?t=1600845

Answer: (credit to Temüjin)

Try removing the .pulse files in your home directory (may have been corrupted by sudden shutdown):

cd ~/
rm -rf .pulse*

Log out and log back in.

share|improve this answer
    
+1 worked for me, but only after reboot, log out/in didn't have any results :) –  Radu Maris Oct 27 '11 at 20:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.