Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've recently installed Ubuntu 11.10 on my PC and I have a resolution problem.

My screen resolution is set at 640x480 (4:3) and I can't see right the whole screen, the windows or the icons. The problem is that it does not have other options in monitor->display so I can choose the right one, and I think that it can't detect my monitor - it says "unknown"(i have a desktop with pentium4, at 3Ghz, asus motherboard and an Nvidia GeForce graphic card).

xrandr: Failed to get size of gamma for output default Screen 0: minimum 320 x 240, current 640 x 480, maximum 640 x 480 default connected 640x480+0+0 0mm x 0mm 640x480 50.0* 320x240 51.0 

lspci -v | grep VGA

VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200] (rev a1) (prog-if 00 [VGA controller]) Subsystem: PROLINK Microsystems Corp Device 1152 Flags: bus master, 66MHz, medium devsel, latency 248, IRQ 16 Memory at fd000000 (32-bit, non-prefetchable) [size=16M] Memory at e8000000 (32-bit, prefetchable) [size=128M] [virtual] Expansion ROM at fe9e0000 [disabled] [size=128K] Capabilities: <access denied> Kernel driver in use: nvidia Kernel modules: nvidia_173, nouveau, nvidiaf 
share|improve this question

closed as off topic by Bruno Pereira Mar 12 '12 at 10:05

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Try xrandr -s 0 instead –  Ashfame Nov 27 '11 at 18:24
1  
@chrissi Welcome to Ask Ubuntu! Can you tell us more about your hardware setup by editing this information back into your question or by posting a comment? Your issue sounds related to your graphics in particular, and this information can help us try to diagnose the cause of your issue. Thanks! –  Christopher Kyle Horton Nov 28 '11 at 2:29
    
@UriHerrera thnx, i got it... it says: xrandr: Failed to get size of gamma for output default Screen 0: minimum 320 x 240, current 640 x 480, maximum 640 x 480 default connected 640x480+0+0 0mm x 0mm 640x480 50.0* 320x240 51.0 now what should i do?? –  chrissi Nov 28 '11 at 15:22
    
I see you added that you have an Nvidia card, again type this in the terminal so that you know which one is specifically: lspci -v | grep VGA –  Uri Herrera Nov 28 '11 at 15:32
    
01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200] (rev a1) (prog-if 00 [VGA controller]) Subsystem: PROLINK Microsystems Corp Device 1152 Flags: bus master, 66MHz, medium devsel, latency 248, IRQ 16 Memory at fd000000 (32-bit, non-prefetchable) [size=16M] Memory at e8000000 (32-bit, prefetchable) [size=128M] [virtual] Expansion ROM at fe9e0000 [disabled] [size=128K] Capabilities: <access denied> Kernel driver in use: nvidia Kernel modules: nvidia_173, nouveau, nvidiaf –  chrissi Nov 29 '11 at 18:04

1 Answer 1

This is only part of the solution working for me! The way I fixed this one on my computer :

  • Step 1

Must find someone (This is the other part of the solution !) with same monitor having a working configuration (Send SOS on forums !) ask him open terminal and use

xrandr --verbose

It will list the exact data you need to use for each resolution. Also at the beginning you will have the information for the monitor number - Mine was VGA1

  • Step 2

You now should copy carefully the one you need in

/etc/gdm/Init/Default

You must adjust the data according to the one found in step 1. Here the data are for my monitor as sample (You may have to sudo to edit it)

xrandr --newmode 1440x900 106.5MHz 1440 1520 1672 1904 900 903 909 934 -HSync +VSync
xrandr --addmode VGA1 1440x900

copy these two lines just before the line

/sbin/initctl -q emit
  • Step 3

log out then back now the resolution you add should be available in the monitor display preferences.

Good luck

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.