Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have two notebooks (Notebook 1 with Ubuntu 10.04 and Notebook 2 with Ubuntu 10.10) in a home network and I want to share a folder on notebook 1 with samba. Notebook 2 should be able to read/write/delete content of the folder.

I installed the packages samba and system-config-samba and I added a user and the share with read/write access to samba with the Samba Configuration GUI.

When I enter

smb://notebook_1/folder

in Nautilus on notebook 2 I can enter username and password. But then I can only read the content of the folder. Changing files is not allowed. Can somebody help me?

edit: Here is the part of my smb.conf, where the share is defined:

[Images]
    path = /home/user1/Images
    writeable = yes
;   browseable = yes
    valid users = avahi, user1

Do I need to add a semicolon in front of writeable...?

share|improve this question
    
Which user did you use to log in to the Samba share? Did you use the username from the user who created the shared folder on notebook 1? –  W. Goeman Oct 19 '10 at 18:31
    
No. The user was created in the Samba GUI. So it is not a user of the system, but a samba user. Maybe I should have added that I had to choose a UNIX-username for the new samba user. I chose "avahi". Don't know if this is correct or not...? –  xilix Oct 19 '10 at 21:15
    
Rather than using SMB (which is primarily for Windows interoperability) is there any reason why NFS isn't an option? –  Cry Havok Oct 20 '10 at 8:27
    
I could also use NFS. I just want to have an easy method to share folders in a home network. –  xilix Oct 20 '10 at 15:37
    
For Linux systems (and other unix systems) NFS is the easy method. –  Cry Havok Oct 20 '10 at 19:55
show 1 more comment

2 Answers

up vote 1 down vote accepted

Try to login to the share with a user which has read/write permissions on the system where the folder is shared. Also make sure that that particular user has rights to access the samba share.

If possible, it is always a good idea to go for NFS sharing. As long as you do not need to connect from a Windows box you will be happy with NFS. If you want to continue with NF have a look at the quick start section of this official Ubuntu documentation.

share|improve this answer
    
The writable flag was not saved for some reason. Now it works with the user-accoutn of notebook1. –  xilix Oct 22 '10 at 13:21
add comment

Try to change the permission to the directory. if your directory sharing path is /home/user1/Images then run chmod 777 /home/user1/Images.

Hope this helps.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.