Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I formatted my whole hard drive, and installed Elementary OS (Ubuntu 10.10) on it in an attempt to get rid of all the problems. It failed.

Every since I installed the nvidia-current drivers I first need to boot into recovery mode, and run sudo nvidia-xconfig before booting the system in the normal way.
If I don't do this, it will just stop at a black screen after the boot screen, responding to nothing but CTRL+ALT+DELETE and the power button.

When I boot the system after running the nvidia-xconfig command I can just start working as usual.


I suspect it's got something to do with Plymouth. I shall have to try it again before I can confirm it, but removing the quiet and splash parameters from the kernel line in /boot/grub/grub.cfg seems to help.
But still, I like my Plymouth screen. A black screen with text rolling over it (or without the text) doesn't attract me much.


It seems this hasn't got anything do do with it, and if it does, it only made things worse. I had to reboot for a full 15 minutes today before I finally got my login screen. Anything that helps would be greatly appreciated, because this is getting extremely annoying.
Also, I'm not so sure anymore if nvidia-xconfig is at all related to this problem. Today I tried running nvidia-xconfig as usual, and it didn't work :s Also I checked what was the difference between the old and the newly genereated /etc/X11/xorg.conf file using diff. Conslusion: There wasn't any difference.

Things like this also won't do the idea that open-source and free software are "cheap, and crappy alternatives for other pieces of software" and that "they are in fact so bad that they can give them away for free because nobody would want to pay any money for it" any good.


I think it must be just totally random. Most of the times it stops at the black screen, and there's about a 1 out of 20 chance that it works.

Some log files


share|improve this question
what boot parameters (if any) have you tried - e.g. nomodeset ? Please add details of your nvidia graphics card lspci | grep VGA . Please confirm the driver you have installed. Also, can you confirm whether you are using the standard maverick kernel or something newer? Have you tried the x-stable PPA? – fossfreedom Nov 29 '11 at 19:16
@fossfreedom Haven't tried any. Only tried removing quiet and splash. 01:00.0 VGA compatible controller: nVidia Corporation G72M [Quadro NVS 110M/GeForce Go 7300] (rev a1), nvidia-current, Linux robin-Latitude-D620 2.6.35-31-generic #62-Ubuntu SMP Tue Nov 8 14:20:11 UTC 2011 x86_64 GNU/Linux (no chance of updating the kernel, anything newer than 2.5.35 seems to overheat my laptop), haven't tried any X PPA's yes as I was under the impression that that was a bad idea. – RobinJ Nov 30 '11 at 12:05
@BrunoPereira That's not my opinion of the matters, I love open-source software. But fact is that that's still how many (if not most), people think about it. And stumbling upon problems like this when they finally try it out doesn't help much :p – RobinJ Nov 30 '11 at 12:09
@RobinJ - ok - dont forget to add this info to your question (tends to get lost in comments). Please try some of my ideas - again add to your question with the results. X-stable PPA is less tested than the default - but as the name intimates often contains drivers that are newer and are known to be more stable than the X-edgers PPA. – fossfreedom Nov 30 '11 at 12:19
@BrunoPereira Strange thing is that there are (only a few) distro's where I don't have any problems at all with the NVidia drivers :p But they've got their own set of problems. – RobinJ Nov 30 '11 at 12:50
up vote 1 down vote accepted

nVidia 260.19.06 drivers are known to be buggy with many users reporting exactly the same issue you have.

That is version that Ubuntu 10.10 uses on the repos so that version of the package will not work for you. You need to remove the package and install a more recent version of the drivers, I recommend the latest version directly from the nVidia site or from the Ubuntu-X team.

share|improve this answer
I removed nvidia-current and added the PPA ppa:ubuntu-x-swat/x-updates. What should I do now? – RobinJ Nov 30 '11 at 13:04
Update with sudo apt-get update if you have not and sudo apt-get install nvidia-current make sure that apt is trying to install 290.10 which is the latest driver version in the PPA. – Bruno Pereira Nov 30 '11 at 13:07
I'm going to wait and see for a day or 2 to see if the problem is really gone before marking your answer as accepted, but it seems like the problem's gone. :D – RobinJ Nov 30 '11 at 13:46
Had no further problems. Thanks :D – RobinJ Dec 1 '11 at 16:02
WTF, I know why this fixed it. It just disabled the NVidia drivers. It's using Nouveau! So I still can't play any games... – RobinJ Dec 5 '11 at 17:08

some part of below link can help to you! i had the same problem! sorry for bad english.

share|improve this answer
... This topic doesn't seem to have anything to do with my problem. – RobinJ Nov 29 '11 at 17:07
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Marco Ceppi Dec 1 '11 at 13:16

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.