Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have ubuntu 11.10 and am trying to install the latest version of kbibtex but I can't do it. Anyone know how to do? I downloaded the tar.bz2 file from KD4 page (, followed the instructions but I get the following error:

~/kbibtex-0.4-beta1/build$ cmake ../ -DCMAKE_INSTALL_PREFIX=home

-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
CMake Error at /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:91 (MESSAGE):
Call Stack (most recent call first):
  /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:252 (_FPHSA_FAILURE_MESSAGE)
  /usr/share/cmake-2.8/Modules/FindQt4.cmake:1162 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  CMakeLists.txt:7 (find_package)

-- Configuring incomplete, errors occurred!

Someone can give me an idea of ​​what's going on?

share|improve this question

Install the necessary QT4 libs before trying to compile a program that needs them:

sudo apt-get install libqt4-dev qt4-dev-tools
share|improve this answer

Compiling software

The Ubuntu has documentation:

The cmake:

Build Depends

The easy way to get the right packages is look what the official packagers are using. Browsing to the or and downloading the kbibtex dsc file.

The latest, at the moment, is the kbibtex_0.4~beta1-1.dsc and it is telling:

Build-Depends: debhelper (>= 7.0.50~), cmake (>= 2.6~), kdelibs5-dev, libpoppler-qt4-dev, libxslt1-dev, libqtwebkit-dev

The debhelper package is needed only if you are building the deb packages. So, packages needed:

  • build-essential
  • cmake
  • kdelibs5-dev
  • libpoppler-qt4-dev
  • libxslt1-dev
  • libqtwebkit-dev

Binaries and more

This site provides you with information about all the packages available in the Ubuntu Package archive.

You could look the if there are new binaries available for the Ubuntu. The Ubuntu Precise Pangolin ( ) is under development an it is getting the new versions.

Personal Package Archives (PPA) allow you to upload Ubuntu source packages to be built and published as an apt repository by Launchpad.

Maybe someone has packed the new version of kbibtex . But note that:

The contents of Personal Package Archives are not checked or monitored. You install software from them at your own risk.

All packages that are included in the official Debian distribution

You could download and install the Debian binaries but be careful. They are Debian not Ubuntu packages. Earlier: No PDF preview in KBibTex.

Requesting new/backported packages

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.