Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have ubuntu 11.10 and am trying to install the latest version of kbibtex but I can't do it. Anyone know how to do? I downloaded the tar.bz2 file from KD4 page (http://home.gna.org/kbibtex/download.html), followed the instructions but I get the following error:

~/kbibtex-0.4-beta1/build$ cmake ../ -DCMAKE_INSTALL_PREFIX=home

-DCMAKE_BUILD_TYPE=BUILD_TYPE && make
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
CMake Error at /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:91 (MESSAGE):
  Could NOT find Qt4 (missing: QT_QMAKE_EXECUTABLE QT_MOC_EXECUTABLE
  QT_RCC_EXECUTABLE QT_UIC_EXECUTABLE QT_INCLUDE_DIR QT_LIBRARY_DIR
  QT_QTCORE_LIBRARY)
Call Stack (most recent call first):
  /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:252 (_FPHSA_FAILURE_MESSAGE)
  /usr/share/cmake-2.8/Modules/FindQt4.cmake:1162 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  CMakeLists.txt:7 (find_package)

-- Configuring incomplete, errors occurred!

Someone can give me an idea of ​​what's going on?

share|improve this question

2 Answers 2

Install the necessary QT4 libs before trying to compile a program that needs them:

sudo apt-get install libqt4-dev qt4-dev-tools
share|improve this answer

Compiling software

The Ubuntu has documentation: https://help.ubuntu.com/community/CompilingSoftware

The cmake:

Build Depends

The easy way to get the right packages is look what the official packagers are using. Browsing to the http://www.debian.org/distrib/packages or http://packages.ubuntu.com/ and downloading the kbibtex dsc file.

The latest, at the moment, is the kbibtex_0.4~beta1-1.dsc and it is telling:

Build-Depends: debhelper (>= 7.0.50~), cmake (>= 2.6~), kdelibs5-dev, libpoppler-qt4-dev, libxslt1-dev, libqtwebkit-dev

The debhelper package is needed only if you are building the deb packages. So, packages needed:

  • build-essential
  • cmake
  • kdelibs5-dev
  • libpoppler-qt4-dev
  • libxslt1-dev
  • libqtwebkit-dev

Binaries and more

http://packages.ubuntu.com/

This site provides you with information about all the packages available in the Ubuntu Package archive.

You could look the if there are new binaries available for the Ubuntu. The Ubuntu Precise Pangolin ( http://ubuntuforums.org/forumdisplay.php?f=412 ) is under development an it is getting the new versions.

https://launchpad.net/ubuntu/+ppas

Personal Package Archives (PPA) allow you to upload Ubuntu source packages to be built and published as an apt repository by Launchpad.

Maybe someone has packed the new version of kbibtex . But note that:

The contents of Personal Package Archives are not checked or monitored. You install software from them at your own risk.

http://www.debian.org/distrib/packages

All packages that are included in the official Debian distribution

You could download and install the Debian binaries but be careful. They are Debian not Ubuntu packages. Earlier: No PDF preview in KBibTex.

Requesting new/backported packages

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.