Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a notebook with NVidia GT520M (which uses Optimus technology) and after a long and bloody fight I finally put it to work through Ironhide.

Last night I let my notebook be out of battery by accident. After reboot and login, the default screen changed from 1366x768 to 1024x768 and the screen brightness init with 0 (screen totally black, brightness adjusted by the keyboard controls). Note that the login screen is Ok, perfect resolution and brightness...

How can I change back this values? And what happened :-T ?

Thank you all!!

Notes:

  • I can't access NVidia settings, always crash Ironhide.

  • When I change the resolution by xrandr or "Screen" interface it'll ok, but I always lost the configuration after reboot.

  • After I install Ironhide for the first time, I reboot the system several times, and it was ok.

share|improve this question
    
Have you activated Power Management through Ironhide? –  Hanynowsky Nov 26 '11 at 23:03
    
Yes, I do... Now I've uninstalled Ironhide and still got this issue... :-/ –  Pedro Rezende Nov 27 '11 at 0:48
    
That lets suppose something is wrong with Xorg config. Did you check xorg.conf file? When you login native resolution and display options change from default to customized. See if something was appended by accident to this file. see also this wiki, to disable nvidia card temporarily. This will show us if the problem is related to Nvidia card or not. wiki.edubuntu.org/HardwareSupport/Machines/Laptops/Dell/XPS/15 –  Hanynowsky Nov 27 '11 at 1:29
add comment

1 Answer

Since the PM feature of Ironhide uses ACPI calls, it's possible that the power loss caused some inconsistency in the ACPI state.

Try pulling out the battery and AC adapter and leave it for a few (5?) minutes. After that, the ACPI state should be reset. Then try booting from a Live CD or Live USB. If that works, try to boot into your installation.

If the Live session works, but your installation does not, try to uninstall the nvidia driver:

sudo apt-get purge nvidia-current
share|improve this answer
    
If your problem is not solved by this, please paste your /var/log/Xorg.0.log and /var/log/kern.log files. –  Lekensteyn Nov 27 '11 at 13:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.