Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've tried to edit the configuration file in ~/.config/openbox/lxde-rc.xml however the changes don't take effect, i still can't use the keys.

The LXDE wiki shows that after finding that my keyboard sends the correct standardized keyboard events i should go and edit the file to my liking, the keyboard does send the correct events and the keys are properly identified yet nothing happens.

Since LXDE doesn't come with a sound preferences option i have installed xfce4-mixer. I too have a netbook running Lubuntu and its media keys are working fine, i don't know if what i installed has had something to do here?.

I also installed xfce4-volumed volume keys daemon from synaptic but to no avail, still nothing.

How can i make the multimedia keys of my keyboard ( Microsoft Wireless Keyboard 1000) work in LXDE with xfce4-mixer

Edit: Here is my lxde-rc.xml file

I've commented the line OnlyShowIn=XFCE: in /etc/xdg/autostart/xfce4-volumed.desktop and now i get a notification when pressing the Volume keys however it doesn't have any effect on the audio output. The Play/Pause, Stop, etc. Keys still don't work.

I also tried to use the commands my XML file has, i.e. amixer sset Master 3%+ and i get this:

  Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined penum
  Playback channels: Mono
  Limits: Playback 0 - 64
  Mono: Playback 5 [8%] [-59.00dB] [on]

Using the command again raises this value Mono: Playback 5 [8%] [-59.00dB] [on] to Mono: Playback 7 [11%] [-57.00dB] [on] but no audible effect is noticed.

share|improve this question

closed as too localized by Marco Ceppi Dec 7 '11 at 1:24

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
On a different note I believe xfce4-volumed is XFCE only startup job. Make sure its running in lxde as well. –  sagarchalise Dec 1 '11 at 7:21
    
basically comment the the line showonlyin: XFCE in /etc/xdg/autstart/xfce4-volumed.desktop. I think ps aux | grep xfce4-volumed would say if process is running or not. –  sagarchalise Dec 1 '11 at 7:34
    
@fossfreedom Done editing the question, i do have pulseaudio installed, killing it causes the volume to drop in dB even when the volume control slider is at the max. –  Uri Herrera Dec 1 '11 at 23:21
    
Uri - just confirming what I think you said - killing pulseaudio and then running the amixer commands manually changes the volume correctly. Having pulseaudio and running the amixer commands manually does not change the volume - hence it is pulseaudio that is clashing with LXDE ALSA Audio. What happens if you just uninstall pulseaudio and reboot. –  fossfreedom Dec 2 '11 at 10:45
    
Killing pulseaudio makes the volume sort of drop in dB, and then if i use the amixer commands to raise the volume they don't do anything. But i will uninstall it and see what happens. –  Uri Herrera Dec 2 '11 at 15:11

1 Answer 1

up vote 0 down vote accepted

I have reinstalled the whole OS due another inconvenience, now i'm using XFCE instead of LXDE

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.