Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was missing icons from menus in Ubuntu 11.10. I tried enabling them by setting menus_have_icons to true in GConf editor, as various answers on this site mention. However, that didn't work.

Then I tried Ubuntu Tweak, and it did work. What is that program doing differently?

share|improve this question

4 Answers 4

up vote 3 down vote accepted

There are many big changes in 11.10. Among them is a new configuration system, called DConf. This replaces GConf, but the transition is not complete among all apps. You may wish to install and explore dconf-editor from the dconf-tools package. It is very similar to gconf-editor, except that many keys have gotten new names. You should be able to figure it out. For instance, if something used to be found in /apps/gnome/something, it may now be found in /org/gnome/something.

share|improve this answer

Gnome3 (as used by Ubuntu 11.10) uses DConf instead of GConf you need to use dconf-editor (package dconf-tools) and set org.gnome.desktop.interface.menus-have-icons

share|improve this answer

gnome-tweak-tool is also capable of managing a lot of these settings.

share|improve this answer

Those settings are likely now in dconf, viewed/set thru dconf-editor or set thru gsettings

org.gnome.desktop.interface in dconf-editor (install dconf-tools

gsettings set org.gnome.desktop.interface menus-have-icons true
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.