Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can watch most DVD's on my machine using VLC but today, I went to watch Thor, and it won't play.

  • libdvdread4 and libdvdcss2 are at the latest versions.
  • vlc -v returns 1.1.4
  • w32codecs are installed and reinstalled
  • ubuntu-restricted-extras are same as above

My machine recognises the disc and I can open the folder and browse the assorted .vob files, of which there are many. None of them will open in VLC, or in MPlayer etc.

When I run vlc -vvv /media/THOR/VIDEO_TS/VTS_03_1.VOB I get:

File Reading Failed VLC could not read the file

I also see command line output like this:

[0x963f47c] main filter debug: removing module "swscale"
[0x963a4b4] main generic debug: A filter to adapt decoder to display is needed
[0x964be84] main filter debug: looking for video filter2 module: 18 candidates
[0x964be84] swscale filter debug: 720x576 chroma: I420 -> 979x551 chroma: RV32 with scaling using Bicubic (good quality)
[0x964be84] main filter debug: using video filter2 module "swscale"

.....

[0x959f4e4] main video output warning: late picture skipped (-10038 > -15327)
[0x963a4b4] main generic debug: auto hidding mouse
[0x93ca094] main input warning: clock gap, unexpected stream discontinuity
[0x93ca094] main input warning: feeding synchro with a new reference point trying to recover from clock gap
[0x959f4e4] main video output warning: early picture skipped

......

ac-tex damaged at 0 12
ac-tex damaged at 6 20
ac-tex damaged at 12 28

This happens with onboard and Known Good USB DVD player I don't have standalone DVD player to try with TV

I am going to watch another film instead for now, because I can do that. I just can't watch THOR, and I'm pretty confident that the disc is ok. It is a rental, but it's clean and there are no surface abrasions. I even cleaned it with Christian Dior aftershave to make sure.

share|improve this question
1  
What happens if you try to play in vlc like normal, from cli as vlc dvd:// –  doug Nov 26 '11 at 16:34
    
Thanks for your suggestion, I tried that, and get libdvdread: Can't stat /dev/dvd No such file or directory along with a few other errors. One thing I have noticed, is that the DVD itself is actually see-through. When I hold it up to the light, I can make out the shapes of objects behind it, so I'm going to take it back and find out if this is dud, perhaps it's something simple like that. –  stephenmurdoch Nov 26 '11 at 16:40
    
Same problem with second identical DVD. –  stephenmurdoch Nov 26 '11 at 17:20

1 Answer 1

up vote 3 down vote accepted

That title has structure protection & is the likely cause of your problem with playback. The protection isn't an issue with the latest couple of libdvdnav4 releases but it appears it is with the version provided in lucid.

Assuming your drive is /dev/dvd, if unsure you could run this & check the /dev/ links

sudo lshw -C disk

Look for the section *-cdrom, if it shows /dev/dvd then use below command, if it says /dev/dvd1 then adjust, you could also use the /dev/srX instead where X is usually 0 or 1

If you are in region 1 then the main movie is title 24 so this may work, -

vlc dvdsimple:///dev/dvd@24 

command means - dvdsimple:// (no menus), /dev/dvd (device), @ title number

(starting in vlc-1.2 the @ is now a #)

Otherwise it's quite possible you can upgrade libdvdnav4 & libdvdread4 to newer versions, there are no real dependency issues. I don't have a lucid install to d. check but shouldn't be an issue.

If so you need to upgrade both packages at the same time, I'd use the 11.10 packages. If you wish to let me know, I'll edit in how.

EDIT: - realized I had a lucid iso so did a quick boot to live session to check out. You may not be able to play Thor with the above method though it could be handy for some other structure protected disks. I went ahead & upgraded the libdvdread/nav libs & you should then have no issue with Thor.

In some cases even with the newer libs you may have to resort to playing by going directly to the main movie title, Cars2 is an example of that, Thor should be fine as normal

To upgrade 10.04 to newer libdvdread/nav

Will use the 11.10 packages, one could use the 12.04 though 11.10 will suffice.

Open a terminal, run this command, then leave the terminal open

sudo apt-get remove libdvdread-dev; mkdir dvd_fix; cd dvd_fix

Then go to these pages, pick your arch, right click on the top listed mirror > save link as, save into dvd_fix folder (it's in your home dir.

http://packages.ubuntu.com/km/oneiric-updates/libdvdread4

http://packages.ubuntu.com/km/oneiric/libdvdnav4

Once both packages are downloaded & in the dvd_fix folder run this in the still open terminal

sudo dpkg -i *.deb

that will upgrade you & disk should play

If you need or think you may need the libdvdread/nav dev files for building related sources

We'll do this way to avoid possible broken packages - do AFTER the above is done

In your dvd_fix folder create a new folder named devs

Go to these 2 pages & download the -dev packages to the dvd_fix/devs folder like before

http://packages.ubuntu.com/oneiric-updates/libdvdread-dev

http://packages.ubuntu.com/oneiric/libdvdnav-dev

When or if you need the dev packages installed then just open that folder, right click on libdvdread-dev & install with gdebi. Then do the same for libdvdnav-dev, do libdvdread-dev first

share|improve this answer
    
thanks, you were spot on, got it fixed. I used sr0 instead of dvd. I learned a few useful things about ubuntu too, so thanks again –  stephenmurdoch Nov 27 '11 at 1:32
1  
Wasn't sure About Thor so edited in how to upgrade 10.04 to latest libdvdread/dvdnav –  doug Nov 27 '11 at 1:37
    
Though maybe you're not on 10.04 (lucid)?? –  doug Nov 27 '11 at 1:40
    
awesome, I'd upvote 2wice if I could. I am on Lucid. Keep meaning to upgrade but it works fine so I keep putting it off... Thanks again, you've been a great help. –  stephenmurdoch Nov 27 '11 at 1:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.