Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am in deep trouble. I am using Ubuntu 11.10 in dual boot mode with XP.

Originally my touch pad was not working, (sometimes). To fix that, I installed something. After reboot my Ubuntu is not booting up!!

I have several software pkgs already installed in past several weeks so reinstall of OS is my last resort. Can someone help me to get it rebooted in graphical mode?

I had followed the procedure mentioned in this thread as well. With that link, somehow I am able to restart in text mode. But no luck after that. I am not being able to go back on graphical mode.

The important outputs of lspci are following:

00.00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 0c)
00:02.0 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 0c)

I am attaching few snapshots, for more details on hardware.

enter image description here enter image description here enter image description here

share|improve this question
    
@fossfreedom, thanks, But I after I chosen "Recover mode", I see 4 options as, resume, fsck, remount, root. Sorry for my ignorance, if I don't know much as I am novice in Ubuntu shifted from XP. –  iammilind Nov 26 '11 at 15:37
add comment

1 Answer

up vote 5 down vote accepted

Finally after lot of struggling, I was able to resolve this issue. And I happily writing this answer from the same Ubuntu which I lost for few hours.

If the Ubuntu is not booting up, then when the blank screen appears press Ctrl + Alt + (F1 to F6, anything) or goto recover mode to check from the command line.

Then, I checked following file:

sudo vi /var/log/Xorg.0.log

It will give you the information, where exactly you are failing. For example, it was failing for me in one of the files which I wrongly edited. See the bold text below.

[    16.685] 
X.Org X Server 1.10.4
Release Date: 2011-08-19
[    16.685] X Protocol Version 11, Revision 0
[    16.685] Build Operating System: Linux 2.6.24-29-server i686 Ubuntu
[    16.685] Current Operating System: Linux Ubuntu11.10 3.0.0-13-generic #22-Ubuntu SMP Wed Nov 2 13:25:36 UTC 2011 i686
[    16.685] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.0.0-13-generic root=UUID=0e1d28e3-b3cc-4022-81c6-4f4d24ac6f63 ro quiet splash vt.handoff=7
[    16.685] Build Date: 19 October 2011  05:09:41AM
[    16.685] xorg-server 2:1.10.4-1ubuntu4.2 (For technical support please see http://www.ubuntu.com/support) 
[    16.685] Current version of pixman: 0.22.2
[    16.685]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[    16.685] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    16.685] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Nov 26 22:59:34 2011
[    16.865] (==) Using system config directory "/usr/share/X11/xorg.conf.d"

**

[ 17.051] Parse error on line 14 of section InputClass in file /usr/share/X11/xorg.conf.d/50-synaptics.conf "ppa:sergio91pt/synaptics+clickpads" is not a valid keyword in this section. [ 17.051] (EE) Problem parsing the config file [
17.051] (EE) Error parsing the config file [ 17.051] Fatal server error: [ 17.051] no screens found [ 17.051] Please consult the The X.Org Foundation support

**

I simply removed that line and rebooted. It again appeared with blank screen, I just tried randomly other tty section (e.g. tty2), by pressing Ctrl + Alt + F2 and I to my pleasant surprise I saw the graphical login screen!!!

I just checked if everything is intact. Also, due to upgrade, I see small changes in usability, but rest is fine otherwise. This is my first successful login after that disaster and I hope that it will continue without any problem in future.

Lesson, I learned were, to fix a small problem don't do unnecessary upgrade/updates and screw your time and energy. Thanks.

share|improve this answer
2  
+1 well done for perservering –  fossfreedom Nov 26 '11 at 17:53
1  
@iammilind - well done, you should accept your own answer too as it solved your problem. –  Mark Rooney Nov 26 '11 at 22:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.