Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i have tried using ubuntu 10.04 and ubuntu 11.10 and both have the same problem the driver is detected by the additional propriety drivers wizard and after installation, ubuntu can't see except on wireless network which is not mine (and i can't connect to it as it is secured)

There are plenty of wireless networks around me but ubuntu can't detect them and if i tried to connect to one of them as if it was hidden connection time out.

the command lspci -nvn | grep -i net gives

04:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)
05:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 05)

iwconfig gives

lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=19 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

i guess it is something related to Broadcom driver .. but i don't know , any help will be appreciated

UPDATE: ok i installed a new copy of 11.10 to remove the effect of any trials i have made i followed the link (http://askubuntu.com/q/67806) as suggested

all what i have done now is trying the command lsmod | grep brc and it gave me the following

brcmsmac              631693  0 
brcmutil               17837  1 brcmsmac
mac80211              310872  1 brcmsmac
cfg80211              199587  2 brcmsmac,mac80211
crc_ccitt              12667  1 brcmsmac

then i blacklisted all the other drivers as mentioned in the link

the wireless is still disabled..

enter image description here

in the last installation installing the Brodcom STA driver form the additional drivers enabled the menu but as i have said before it wasn't able to connect or even get a list of available networks

so what should i do now ?

the output of command rfkill list all rfkill list all

0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
share|improve this question
    
please follow this answer and add to your question what you have tried. Thanks. askubuntu.com/q/67806/14356 –  fossfreedom Nov 26 '11 at 14:40
    
according to what i understood this driver brcm80211 is found in ubuntu 11.10 so how can i enable it ? or should i download the sources and compile as the ubuntu forum link illustrates ? –  Ahmed Kotb Nov 26 '11 at 15:58
    
@fossfreedom , i have updated the question –  Ahmed Kotb Nov 27 '11 at 11:04

1 Answer 1

up vote 1 down vote accepted

Finally i was able to fix the problem using this link

http://tuxcanfly.appspot.com/2011/10/Ubuntu-11-10-Broadcom-Wifi-driver-43xx

the brcmsmac driver (inspire that every one recommends it for bcm4313) had problems with ubuntu 11.10 , the solution was just to blacklist it and install bcmwl-kernel-source

the instructions on the link are easy to follow

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.