Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to install zRam using following commands in terminal -

sudo add-apt-repository ppa:shnatsel/zram
sudo apt-get update
sudo apt-get install zramswap-enabler

But it throws the following error which says that the package is not available,

E: Couldn't find package zramswap-enabler

I could not even find any repository with name shnatsel/zram or similar in my system.

As an alternative, i tried to install it from its deb file, which throws dependency error even though i have kernel 2.6.38-13-generic installed in my system.

Dependency Error:

Error: Dependency is not satisfiable: linux (>= 2.6.37.1)|linux-image (>= 2.6.37.1)|linux-generic (>= 2.6.37.1)|linux-image-generic (>= 2.6.37.1)|linux-image-generic-pae (>= 2.6.37.1)|linux-server (>= 2.6.37.1)|linux-virtual (>= 2.6.37.1)|linux-image-server (>= 2.6.37.1)|linux-image-virtual (>= 2.6.37.1)

Is there any way to fix it ?

share|improve this question
    
I presume you downloaded the i386 natty deb? also - the deb wont work with 64bit. What are you using? Add the dependency error when you attempt to install. –  fossfreedom Nov 26 '11 at 14:23
    
@fossfreedom Its ubuntu 10.04 32bit and here is the error -- Error: Dependency is not satisfiable: linux (>= 2.6.37.1)|linux-image (>= 2.6.37.1)|linux-generic (>= 2.6.37.1)|linux-image-generic (>= 2.6.37.1)|linux-image-generic-pae (>= 2.6.37.1)|linux-server (>= 2.6.37.1)|linux-virtual (>= 2.6.37.1)|linux-image-server (>= 2.6.37.1)|linux-image-virtual (>= 2.6.37.1) –  user24665 Nov 26 '11 at 14:28
    
have you install the 2.6.38 headers? - as an aside - welcome to AskUbuntu. When replying to comments with extra information, remember to edit your original question. Stuff like your comment is hard to read because its unformatted. Thanks. –  fossfreedom Nov 26 '11 at 14:32
    
@fossfreedom yep i have installed it, n i appreciate your advice :D –  user24665 Nov 26 '11 at 14:39
    
open up synaptic and search for each of those dependencies - ensure they have the green "i'm installed" symbol. Confirm that the version installed is greater than 2.6.37.1 –  fossfreedom Nov 26 '11 at 14:43

3 Answers 3

up vote 1 down vote accepted

That ppa is for Ubuntu 11.04 / 11.10 (as you can see when you click on technical details).

That is also the reason for your dependency error when you try to install the .deb manually.

share|improve this answer
    
You are correct. The ppa is only for 11.04/11.10 –  Mike Nov 27 '11 at 4:01

For older versions: below are the exact steps as mentioned on its official Launchpad page.

On older (pre 9.10) Ubuntu systems

Step 1: Visit the PPA's overview page in Launchpad. Look for the heading that reads Adding this PPA to your system and click the Technical details about this PPA link.

Step 2: Use the Display sources.list entries drop-down box to select the version of Ubuntu you're using.

Step 3: You'll see that the text-box directly below reads something like this:

deb http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu jaunty main deb-src http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu jaunty main

Copy those lines.

Step 4: Open a terminal and type:

sudo gedit /etc/apt/sources.list

This will open a text editor containing the list of archives that your system is currently using. Scroll to the bottom of the file and paste the lines you copied in the step above.

Save the file and exit the text editor.

Step 5: Back on the PPA's overview page, look for the Signing key heading. You'll see something like:

1024R/72D340A3 (What is this?)

Copy the portion after the slash but not including the help link; e.g. just 72D340A3.

Step 6: Now you need to add that key to your system so Ubuntu can verify the packages from the PPA. In your terminal, enter:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 72D340A3

Replace 72D340A3 with whatever you copied in the step 5.

This will now pull down the PPA's key and add it to your system.

Step 7: Now, as a one-off, you should tell your system to pull down the latest list of software from each archive it knows about, including the PPA you just added:

sudo apt-get update

Now you're ready to start installing software from the PPA!

share|improve this answer
    
there is no version for ubuntu 10.04 :(, thanx for your help though :D –  user24665 Nov 26 '11 at 13:52
    

See my question here or rather the answer to the question (also by me :P). It's exactly your scenario.

share|improve this answer
    
Does not look the same to me...this question is asking about why zramswap-enabler installation is failing, not how to configure it. At any rate, you should flag questions as duplicates rather than posting answers in the future (although I doubt this is a duplicate). –  Christopher Kyle Horton Nov 27 '11 at 4:30
    
zramswap-enabler just does the same thing afaik. If for whatever reason the script doesn't work this kind of solves the problem. –  turbo Nov 27 '11 at 12:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.