Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use 11.10 with gnome 3 and Unity. In either case, I use two KDE apps a lot - kile and kate. Since the latest upgrade, I have observed a few problems:

a] I can never use Alt+F to select the file menu (works with other apps), yet when I press Alt, kile's menu comes up in the status bar.

b] A few times every day, while using kile (haven't used kate as much recently), the keyboard stops responding (just in the 'editor' portion, rather than in structure-tree navigation). I cannot enter any text, but mouse works fine. I usually restart kile to continue working.

One inconsistent way to reproduce it (multiple times today):

  • I cut text from one open document using Ctrl+X

  • switched to another document in the same kile window using Ctrl+Tab, then this happened.

c] Sometimes, in kate, I can type in the editor but the keyboard won't work in the File open dialog.

How do I fix the above?

share|improve this question
    
Related question. –  vishvAs vAsuki Nov 26 '11 at 15:48
add comment

3 Answers

up vote 2 down vote accepted

Sorry, not an answer. Just something to confirm similar issues with Kile. However, mine is through KDE for Windows. Some .tex files won't let me edited them in the editor using the keyboard. Can't copy paste either, but I can move the cursor around and scroll through the .tex file. I filed a bug on KDE's website here: https://bugs.kde.org/show_bug.cgi?id=292766

4-30-12: Again, not an answer, but now I am experiencing similar problems with the keyboard input after upgrading from 11.10 to 12.04. This is really frustrating as documents (.tex files) that worked fine before no longer allow me to type in them. I can select and scroll with the mouse but no typing!!!! Funny thing too is that it only happens for a few documents.

share|improve this answer
1  
Aha! I think I found an answer!! My solution was simple...of course. For some reason, the Read Only mode was enabled!! So simple go to Tools and disable!! That's it! Now my issues with Kile and the keyboard input are resolved on both Windows KDE and after I upgraded from 11.10 to 12.04!! Thanks to the responses I got from the KDE community where I posted this "bug" (see link in original post)!!! –  timmay143 May 6 '12 at 19:46
    
Additional note, apparently Kate and Kile have a restriction on the number of characters per line (1024), and if exceeded, it will open the file read-only. I did receive this error after the upgrade and of course I ignored it because I did not think it was relevant. –  timmay143 May 6 '12 at 19:53
add comment

As the Tools and Settings are side by side, sometimes it's possible to enable "Read Only Mode" accidentally instead of selecting something else like "Define Master Document".

Solution :

Go to Tools > then check if the Read Only Mode is activated. If yes, deactivate it.

share|improve this answer
add comment

I was able to solve the problem deleting the kilerc file in .kde/share/config/. This will reset all your Kile settings, but solves the issue describes in the original post.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.