Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently dual booted my PC with Ubuntu 11.04 and Windows 7. It all worked fine for a few days but one day I logged in and instead of getting the log-in screen, I got this :

BusyBox v1.17.1 (Ubuntu 1:17.1-10ubuntu1) built-in shell (ash)
Enter 'help' to see a list of built-in commands. 

I haven't been able to fix it. How do I get the user interface back?

share|improve this question

migrated from Nov 25 '11 at 20:39

This question came from our site for professional and enthusiast programmers.

Related, but for 11.10 -… – BoltClock Nov 25 '11 at 20:43

Your Ubuntu system is having a boot problem well before it gets to the login screen; this is not actually a login problem, specifically.

Some problems that present in this way can be fixed by reinstalling GRUB2 to the Master Boot Record. You can do that with any of these techniques. If that does not fix the problem, please edit your question to indicate this, and also provide details about what technique you used for reinstalling GRUB2 to the MBR and what happened when you tried (as if it doesn't work, it's possible that your problem is not one that can be fixed this way, but also possible that there was a problem in reinstalling GRUB2 to the MBR).

By the way, the advice in this answer also pertains to Ubuntu 11.04.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.