Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I added the Gnome 3 PPA, to try to install the newst version of the Epiphany web browser, as recommended on a web site @ http://www.omgubuntu.co.uk/2011/11/how-to-install-epiphany-web-app-mode-in-ubuntu/ , only to get the following error upon doing so:

Failed to load the package list. This is a serious problem. Try again later. If this problem appears again, please report an error to the developers.

The error message within the scrollable frame states:

E:Type 'n' is not known on line 1 in source list /etc/apt/sources.list.d/gnome3-team-gnome3-oneiric.list

Is there a way of easily fixing this, or do I need to reinstall the system, which is what I did the last time I had a serious ppa/install error?

When I run, sudo apt-get update , I get this in returned:

E: Type 'n' is not known on line 1 in source list /etc/apt/sources.list.d/gnome3-team-gnome3-oneiric.list E: The list of sources could not be read.

share|improve this question

closed as too localized by Jorge Castro, Marco Ceppi Nov 26 '11 at 0:00

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

2  
Try this: go to Software Center and then click Edit -> Software Sources.... In Other Software separator you have all your ppa's. Delete the one you having problems, update and add it again (with add-apt-repository). If this doesn't solves the problem, you should post the content of /etc/apt/sources.list.d/gnome3-team-gnome3-oneiric.list to your question. –  Salem Nov 25 '11 at 19:21
    
Well the system is telling you what is wrong and where, open the file with nano in the terminal like this sudo nano etc/apt/sources.list.d/gnome3-team-gnome3-oneiric.list –  Uri Herrera Nov 25 '11 at 19:22
1  
@ Salem, when I try to remove from the Software Sources, it does nothing. I can edit the entry, but cannot remove it. When I try your second suggestion in the terminal, I get "Permission denied." @ Uri Herrera, I'm not a technical person, so when I run your suggestion, I have no idea what nano is, or what the information is telling me. As it stands now, I'm stuck. Thanks for commenting back to me on this however. I appreciate it. –  user35397 Nov 25 '11 at 21:13
    
I've attempted to purge the ppa and got the following result: E: Type 'n' is not known on line 1 in source list /etc/apt/sources.list.d/gnome3-team-gnome3-oneiric.list E: Type 'n' is not known on line 1 in source list /etc/apt/sources.list.d/gnome3-team-gnome3-oneiric.list E: The list of sources could not be read. E: Type 'n' is not known on line 1 in source list /etc/apt/sources.list.d/gnome3-team-gnome3-oneiric.list E: The list of sources could not be read. Warning: Something went wrong, packages may not have been reverted –  user35397 Nov 25 '11 at 21:32
    
Alright, I was able to get into the etc/apt/sources.list.d/ and found that when I copied the link from the above mentioned website, a hidden character 'n' was in front of the 'deb' portion at the beginning of the line. I made the edit, and removed the troublesome 'n' and saved the source file. Upon running sudo apt-get update , everything went back to normal. Thanks again for your assistance. I'm not that technical, but I was able to piece enough together to get the change made and the problem resolved. –  user35397 Nov 25 '11 at 22:18

1 Answer 1

Dash open the dash and open software sources


software sources
select the package that has the problem an press remove, and you will be prompted to enter your password the the package is remove.Then open the terminal and run sudo apt-get update

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.