Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got two microphones. Both works good under Windows. If i use them under Ubuntu the first one (call it X) works fine, but the second one (call it Y) produces a lot of high-frequency noise. I know, the best thing to do is to buy a new microphone, but X is really old and the headset are broken, Y is almost new and works fine under windows. Is there any way to apply a low-pass filter in ALSA? I've also noticed that the sound is a little bit softened...like a telephone quality input.

My soundcard is: 00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02) i've got a toshiba notebook and I've just tried to edit the alsa config file adding this line: options snd-hda-intel model=auto

~ UPDATE ~ If i use arecord test.wav -f CD everything works fine.

share|improve this question

2 Answers 2

up vote 4 down vote accepted

I have just solved the problem: it is just a new kernel bug. You can solve it by using:

options snd-hda-intel model=<your_model_or-audo> position_fix=2

In /etc/modprobe.d/alsa-base.conf

share|improve this answer
    
Thank you very much!!! I spend two days in internet in searching about acer aspire one 532h internal microphone noise (with sound card Intel Corporation N10/ICH 7 Family High Definition Audio Controller aka Realtek 272). This fix my internal mic noises. Important: You need to adjust mic volume with the terminal alsamixer tool!!! –  user54950 Apr 14 '12 at 18:05

I just had to open

alsamixer

and go to capture screen [F4] and set mic boost down, and mic record up.

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.