Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I just upgraded from 10.04 to 10.10 following this method, but now when I'm choosing Ubuntu in my GRUB, the screen with the Ubuntu logo appears for like 2 sec and then my screen just go in "idle" mode (the computer is still running) and I can't do anything else than doing a force restart of the machine.

I tried to launch the Recovery mode, I logged in and when I entered startx same thing happened.

I really have no idea of what the problem is, so if someone has one, please let me know.

(I don't know what other details I could give you, so just ask if you need something else)

EDIT

I tried the "Repair broken packages" option in the "Recovery mode" and I get the error that it can't remove fglrx. I tried:

sudo apt-get remove --purge xorg-driver-fglrx fglrx*

but it won't remove it. I get:

...
dpkg-divert: mismatch on package
  when removing 'diversion of /usr/lib/libGL.so.1.2 to /usr/lib/fglrx/libGL.so.1.2.xlibmesa by fglrx'
  found 'diversion of /usr/lib/libGL.so.1.2 to /usr/lib/fglrx/libGL.so.1.2.xlibmesa by xorg-driver-fglrx'
dpkg: error processing fglrx(--remove):
  subprocess installed post-removal script returned error exit status 2
Processing triggers for ureadahead ...
Errors were encountered while processing:
  fglrx
E: Sub-process /usr/bin/dpkg returned an error code (1)

So I guess this is my problem, how could I fix that?

(My video card is the Asus EAH4870)

share|improve this question
    
This is a problem with your graphics card drivers, you needed to remove them before the upgrade. You can still do it but for more advice you need to add more hardware information. Please do so by editing your question. –  Bruno Pereira Nov 25 '11 at 18:51

1 Answer 1

up vote 1 down vote accepted

So I finally found my solution thanks to these two sites: here and here.

The first one, with the response of Toon Macharis, helped me to resolve my dpkg:divert problem (need to modify the fglrx.postrm file), and then I was able to purge fglrx with the very good explanation of the second site.

Everything's working now.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.