Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using gnome-shell in Ubuntu 11.10. I am getting annoyed when dash search lists Recent Items. I have tried many ways to prevent it like

  • Deleting activity.sqlite and activity.sqlite-journal files under ~/.local/share/zeitgeist

  • Adding all the possible entries in Activity Log Manager to prevent application logging

  • Specifying time range in Activity Log Manager to forget my activities.

But none of the methods are working. The recent items list is still populated.

Is there any way to tell dash not to list Recent Items while searching, other than the above methods? Or is there any way to delete the recent items list?

share|improve this question
up vote 20 down vote accepted

Gnome-shell uses recently-used and not Zeitgeist to display your recent items.

to disable it follow theses steps:

delete recently-used.xbel:

rm ~/.local/share/recently-used.xbel

create a new empty file:

touch ~/.local/share/recently-used.xbel

make sure the new file cannot be modified:

sudo chattr +i ~/.local/share/recently-used.xbel

now, your display of recent items is gone.

If you want to revert back, remove the i attribute of recently-used.xbel:

sudo chattr -i ~/.local/share/recently-used.xbel

all credits to :

share|improve this answer
Thanks for your reply. I have a problem here. File ~/.recently-used.xbel does not exist. What should I do? – Vivek Nov 25 '11 at 14:14
Oops, location has changed. I'll edit my post. – severin Nov 25 '11 at 14:18
No effects for me in 12.04 – umpirsky May 15 '12 at 21:28
You can only use chattr with ext2/3/4 filesystems. – MV. Jul 20 '13 at 22:42

Install " Activity Log Manager" using Synaptic and choose apps whose logs you wana see and whose not.

share|improve this answer

There's also an extension Remove recent items search provider for removing the Recent Items provider now, as well.

share|improve this answer

Another approach is here:

$ cat ~/.gtkrc-2.0

$ cat ~/.config/gtk-3.0/settings.ini
share|improve this answer

use cairo dock to delete your recent history... instal cairo dock first,,and then run it,, right click on recent-events,,,then choose "Delete today's events" or "Delete all events" I hope it can help

share|improve this answer
Hi John, can you explain better the steps to do each part you mention here. This way it helps more people that might not understand the system easily. – Luis Alvarado Nov 20 '12 at 14:24

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.