Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have the following Wireless adaptor Intel Corporation Centrino Ultimate-N 6300 (rev 35) Ever since I installed Ubuntu 11.10, I am unable to connect to an ad-hoc network. I assume it is not getting the ip address. Anybody with the same Wireless adaptor facing this issue on Ubuntu 11.10 (Shell) ? This used to work perfectly in Ubuntu 11.04.

share|improve this question
    
Can you edit the question to include the output of sudo lshw -C network –  david6 Dec 19 '11 at 21:33
    
I'm having the same problems as OP - can't connect to Android mobile hotspot. What part of the output would you like to usee ? My wireless interface product: AR242x/AR542x. Vendor: Atheros. Bus info: pci@0000:03:00.0. config: broadcast=yes driver=ath5k driverversion=3.0.0-16-generic firmware=n/a wireless=IEEE 802.11bg –  echoblaze Mar 1 '12 at 21:42
add comment

2 Answers

  1. Make sure connection network is available in your list. If not then enter these lines in terminal:

     sudo rfkill unblock all
    

    This one enable your wireless networking.

  2. Edit connection > Select network which you want to connect and Edit. In IP section try manual for adhoc. For example:

    IP: 192.0.0.1
    netmask: 255.255.255.0
    gateway: 0.0.0.0

    and then connect your ad-hoc network

share|improve this answer
add comment

Try this: Go to network connections -> Wireless choose the network you want to connect select edit->ipv6-settings->ignore

A technical note: We can use our wifi adapter (NIC) in four modes: managed, monitor, ad-hoc and Access Point(master).

Managed: It is the default mode. It helps us to connect to access points only. So if you are connected to AP it means your card is in managed mode.

Monitor: In this mode you don't connect to any of the networks but simply catch the packets in air. Usually used for hacking wifi passwords.

Ad-hoc: It is like a P2P connection. If two machines are connected via an ad-hoc connection both the machines should be in ad-hoc mode , using managed mode you can't connect to an ad-hoc but only access point.

Access Point: In this your card behaves like a router/access point. You need HostAP daemon to create an AP.

Now, if you can't create an ad-hoc connection this means your driver does not support ad-hoc mode and hence you can't connect to an ad-hoc network. But you should always be able to connect to an AP.

share|improve this answer
    
i tried this and it didn't work =( –  echoblaze Mar 1 '12 at 21:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.