Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu 11.1 on my desktop pc. It was a clean install, no upgrading. I have a Samsung Syncmaster BX2450 connected to the PC.

My problem is that I cannot make Ubuntu recognize my monitor - which is capable of more than 1024. I ran a shut down of lightdm, and ran sudo X -configure, but it gave me a "configuration failed". Nothing seems to work - any ideas?

VESA: GF119 Board - 13100000

xx@xxx:~$ lspci -nn |grep VGA
02:00.0 VGA compatible controller [0300]: nVidia Corporation GT520 [GeForce GT520] [10de:1040] (rev a1)

xx@xxx:~$ xrandr -q
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
   1024x768       61.0* 
   800x600        61.0  
   640x480        60.0  
  • I downloaded the driver directly, installed it according to Michael K's answer. But I am back to square one - the screen gets to the purple start color - and locks. Any suggestions as what to do now?

I would very much like to use 1920 x 1200

share|improve this question
    
I suggest to try the proprietary driver from NVidia! –  Michael K Nov 25 '11 at 12:15
    
I tried that during my first installation attempt. This meant that I could not access the gui at all. –  Jens Nov 25 '11 at 13:40
    
no, try it with the driver downloaded directly from nvidia. I never had troubles that way. I described the installation procedure here: askubuntu.com/questions/80121/… –  Michael K Nov 25 '11 at 13:51
    
what resolution would you like to use ? 1920 x 1200 ? 1440x900 ? –  severin Nov 25 '11 at 15:47
    
what's your output of glxinfo | grep render ? –  severin Nov 25 '11 at 22:55

2 Answers 2

I had a different Samsung Syncmaster monitor, and it was unable to correctly communicate its native resolution to the OS. The solution is to write a /etc/X11/xorg.conf that specifies the desired screen resolution. Mine looks like this when using the nvidia binary driver:

# Need a xorg.conf because the native resolution of the SyncMaster 920N
# monitor is misdetected. Plus I'm using the binary nVidia driver.

Section "Monitor"
        Identifier      "SyncMaster920N"
        Modeline        "1280x1024@60" 109.00 1280 1368 1496 1712 1024 1027 1034 1063 -hsync +vsync
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "GeForce9600GT"
        Monitor         "SyncMaster920N"
        DefaultDepth    24
        SubSection "Display"
                Depth           24
                Modes           "1280x1024@60"
        EndSubSection
EndSection

Section "Module"
        Load    "glx"
EndSection

Section "Device"
        Identifier      "GeForce9600GT"
        Driver          "nvidia"
        Option          "NoLogo"        "True"
        Option          "ModeValidation" "NoDFPNativeResolutionCheck, NoMaxPClkCheck, NoHorizSyncCheck, NoVertRefreshCheck"
EndSection

The numbers in the Modeline line (from 109.00 onwards) should be replaced with the "Modeline" numbers that you obtain from running:

cvt <x-resolution> <y-resolution>

replacing <x-resolution> and <y-resolution> with the desired values. The two occurrences of "1280x1024@60" in the file can be changed to anything you'd like, so long as both of them are the same.

For the nouveau driver, remove the Option lines in Section "Device", and change the value of Driver to "nouveau". Note that the safest way of switching between nouveau/nvidia is to [un]install nvidia-current in addition to modifying xorg.conf.

share|improve this answer

Have a look at the relevant Ubuntu wiki - X/Config/Resolution

the relevant part for you starts at: 5. adding undetected resolutions

share|improve this answer
    
the output of the glxinfo | grep render says: direct rendering: Yes OpenGL renderer string: Software rasterizer GL_EXT_vertex_array_bgra, GL_NV_conditional_render, –  Jens Nov 26 '11 at 14:07
    
Did you only try to install the nvidia drivers manually or also with apt-get ? (if you didn't, please don't do so, just tell me.) –  severin Nov 26 '11 at 14:21
    
I installed them manually –  Jens Nov 26 '11 at 14:25
    
please uninstall the nvidia drivers first: sudo /usr/bin/nvidia-installer --uninstall then try Kano's (the man behind the Kanotix distribution) script. you can get it here. open a virtual terminal ctrl+alt+f1 and run the script as sudo. –  severin Nov 26 '11 at 14:39
    
ran the script - which apparently ran its length. Then screen went black, locked. I did a power shut down, started the pc - and now its stuck in the purple screen again –  Jens Nov 26 '11 at 15:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.