Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I need to move data to /var/lib/tftpboot. I'm getting the error Device or resource busy. I killed the tftp daemon which uses this directory, and ran lsof +D /var | grep tftp which gave no output. But I still can't copy my files. Any ideas? I tried already with sudo.

The output of sudo strace touch /var/lib/tftpboot/test can be seen here.

share|improve this question

closed as too localized by RolandiXor, Eliah Kagan, Tom Brossman, hhlp, gertvdijk Jan 2 '13 at 11:07

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Could you paste the output of sudo strace touch /var/lib/tftpboot/test ? –  Jeremy Kerr Nov 25 '11 at 7:12
    
pasted the output of the command, could you explain to me what you want to examine through this command, so i can learn something too ^^? –  Jay Nov 26 '11 at 1:13
    
I'm looking to see if writing to that directory is causing an error - looks like it isn't, as the open() syscall (on line 130) succeeds. –  Jeremy Kerr Nov 28 '11 at 1:06
    
This would indicate that writing to that directory is working. Perhaps it can't read the files that you're trying to copy/move? Are you able to copy or move these files to a different location? Could you let us know how you're trying to 'move the data'? –  Jeremy Kerr Nov 28 '11 at 1:07
    
This question appears to be abandoned and unanswered, could you perhaps add more detail to your question? If this question no longer applies then you can either delete it or answer it yourself if you've solved the problem. Thanks! –  RolandiXor Jan 2 '13 at 5:06

Browse other questions tagged or ask your own question.