Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm just recently used Ubuntu 11.10 for a change. I've install it on a Dual-boot with Windows 7 - but eventually going to remove Windows. I'm using a Asus K42Jc having an NVidia GeForce 310M chip. After installing ubuntu and following some steps on how to install nvidia on my laptop using the codes below, I can't still get my NVidia driver display on the System Info as the Graphics Driver.

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current

I wanted to have this setting for me to install Blender, Warcraft III, etc. How can I resolve the matter?

Thanks in advance.

share|improve this question
    
Does your laptop switches between graphics cards when using Windows? –  Uri Herrera Nov 25 '11 at 2:36
    
Yes. By default on Windows 7 64bit, it uses the Intel HD Graphics but when I always run heavy graphic utilization programs on NVidia via "Run on graphics processor" option. –  Dr. Java Nov 25 '11 at 5:18
    
Then you have 2 options: 1)Use bumblebee to switch between the Intel and the nvidia cards 2)use only the intel card for everything, that's why the driver won't pick your card –  Uri Herrera Nov 25 '11 at 7:29
    
Will try your suggestion. Kindly post it as an answer... Sorry for the late reply. –  Dr. Java Nov 26 '11 at 12:12

2 Answers 2

If you want to change some settings on Nvidia cards type following in terminal ( What is the terminal? )

sudo apt-get install nvidia-settings

This will install an app for making some changes to Nvidia settings. You can find it in unity by typing nvidia setting

share|improve this answer

Disable optimus technolgy from bios. Bumblebee still is experimental but you can try it.

share|improve this answer
    
Sorry for the late reply. Can you supply a link for me to switch form Optimus to Bumblebee? –  Dr. Java Jan 16 '12 at 19:34
    
@Dr.Java See askubuntu.com/a/36936/6969 –  Lekensteyn Jan 21 '12 at 9:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.